Black screen after GRUB, can't install Fedora Workstation 40

I am trying to install Fedora Workstation 40 on a second drive on my computer. Unfortunately after trying to boot from USB, after GRUB I only see a black screen, the computer becomes unresponsive ( even the plugged in keyboard is seen not working).

My specs:
AMD Ryzen 5 7600
MSI GeForce RTX 4060 Ti Gaming X SLIM 16GB GDDR6
Kingston FURY 32GB (2x16GB) 5600MHz CL36 Beast RGB EXPO AMD
Lexar 512GB M.2 PCIe NVMe NM620 (the drive I want to install Fedora on by default)

I’ve already tried editing GRUB by adding nomodeset and/or nouveau.modeset=0, tried enabling Fedora in troubleshoot mode, tested different flash drives, prepared them via Rufus on Windows and Gnome Disks on Debian, tried with and without secure boot, disabled fast boot in Windows.

I have no idea what else I can do, I would appreciate suggestions and help.
Additionally, I tried other distros and achieved the same result, black screen after GRUB screen.

EDIT: Tried Fedora Media Writer too, no success.

this might be nvidia drivers issue untill those are installed boot from safe mode and install nvidia drivers from rpm-fusion. restart and should work if not then troubleshoot continues

Thanks for quick reply.
Sorry if question is stupid, but how can I boot from safe mode and install drivers from rpm-fusion when I don’t have Fedora installed yet? It’s only live USB and Windows on second drive.

boot from USB on grub select troubleshoot pick boot from safe mode

install fedora restart boot to fedora might already work as should setup fedora as normal and then follow Howto/NVIDIA - RPM Fusion to install drivers to nvidia if secure boot enabled there is section for that too

1 Like

Unfortunately, I don’t have safe mode option under troubleshoot. I have only Start Fedora-Workstation-Live 40 in basic graphics mode, and it’s not working too.

basic graphics is same

Do you have access to another PC?

And it’s not working unfortunately.

hi, I don’t think it’s an nvidia driver problem but just in case try using integrated gpu istead of dedicated ==> how to enable integrated graphics in bios - Google Search

Here the official “how to” of RPM fusion → Enabling the RPM Fusion repositories :: Fedora Docs

In your case I would reinstall, perhaps the installation is corrupt. Download it again with fedora media writer and try the installation again.

Nvidia drivers:
-Enable rpm fusion repositories

-Install nvidia drivers

  • sudo dnf update -y

reboot if the “dnf update” update something… and then:

  • sudo dnf install akmod-nvidia

optional for cuda/nvdec/nvenc support:

  • sudo dnf install xorg-x11-drv-nvidia-cuda

src → Howto/NVIDIA - RPM Fusion