Any way to run OBS on Fedora Asahi Remix 39 as of now?


I’ve seen people running it with:


But mine still gives me:

Failed to initialize video. Your GPU may not be supported, or your graphics drivers may need to be updated.

And if it is impossible to use OBS, is there a convenient way to record screen on KDE? I have been using wf-recorder on Hyprland, but now that I am trying out KDE, everything I’ve tried so far doesn’t seem to work.

It does work with those overrides, I just tested it.


(don’t need the GLES one)


I was probably using the variables the wrong way. Either way, it does indeed work and I hope this post helps someone in the future. Thanks!

Your hope will more likely come true if You mark @marcan reponse as a solution.

I doubt I can do this, unfortunately, due to my initial mistake of posting this question in “Asahi General” and not “Ask Asahi”. The “Solution” button is missing here.

Edit: Moved the post to “Ask Asahi”.

Since it was a question, I didn’t read categories and tags. I just assumed, and assumptions are mother of all f(ailure)s. :blush: Sorry.

For what it’s worth, Spectacle also supports screen recording and is preloaded in the KDE environment.

I have tried that and managed to get it working, but it would only save .webp outputs, which was not ideal. Now, however, even saving a .webp recording results in a crash, not exactly sure what causes it.

Recording with h.264 requires ffmpeg from RPM Fusion and libx264, it doesn’t work with openh264. But the quality is still terrible. I think the issue is just that spectacle’s default quality setting is bad and not configurable, for both codecs. Hopefully in the future they’ll add an option for this (video recording in general is a fairly new feature so I assume improvements are coming).

I see the problem lol, Spectacle is using a fixed bitrate which means as screen resolution increases, quality falls over. Yeah, that makes it unusable on HiDPI machines. I’ll file a bug if there isn’t one yet.

Edit: Actually it looks like it gets set based on dimensions somehow, but anyway the whole thing is very broken. It doesn’t even work with most window recording since it errors out due to odd window widths. The whole thing is quite broken, so I would not consider spectacle usable for screen recording at this time.

Edit: Bug 1, Bug 2, Bug 3

1 Like

Oh! This is the good news I picked up today.

I was troubled by this issue for a long time. And now I finally know that MESA_GL_VERSION_OVERRIDE=3.3 MESA_GLSL_VERSION_OVERRIDE=330 obs is working!

In case some have the same problem as me: There should be one more step to be done, which is to downgrade xdg-desktop-portal to v1.14.6 and everything will be done.

1 Like

A little tip I learned, if you don’t want to launch from the cli all the time you can edit /usr/share/applications/com.obsproject.Studio.desktop and change the Exec line to:

1 Like

Even better, instead of modifying /usr/share/applications/com.obsproject.Studio.desktop copy it to ~/.local/share/applications/ and add the env variables there. This way your desktop file won’t get overwritten if the package ships a new desktop file.


Yes, thank you!

I know there’s a solution already, but did you try the Flatpack? According to the OBS website, flatpack is their official way of shipping on Linux. I’ve used it on both KDE and Gnome and it works great.

I think you would need flatpak asahi mesa drivers for that to work.

There is a gihub repo for it but I’m not smart enough to know how to set that up :slight_smile:

Flatpaks in general aren’t going to solve any problems over properly packaged software (as much as the app authors would like them to), certainly nothing Asahi-specific. Right now Flatpaks are basically unusable due to not having the Mesa drivers packaged (it’s on my list), but even then you’d be hard pressed to find a situation where the Flatpak works better on Asahi specifically for some reason.

1 Like