Which screencasting app actually works?

I have a pretty bad frustration with screencasting apps on Linux. I haven’t been able to find a single one with a simple interface that does what I want reliably: Record a single window, with audio and include the mouse pointer, under Wayland, in KDE.
Searching for “screencast” in KDE Discover, I get four useful results:

  • RecApp (GTK): It doesn’t support Wayland, starting a recording is not possible
  • Blue Recorder (GTK): Also not working. Something’s wrong with the record button, and the “select window” is broken: the cursor turns into selection pointer only on the Blue Recorder window, not on other windows.
  • Peek (GTK): Interacting with the system becomes impossible once the recording is started, windows behave unexpectedly.
  • VokoscreenNG: Wayland support is experimental…
  • Spectacle: KDE’s standard screenshot tool is now also supposed to record video of the screen - except it crashes as soon as I stop the recording.

EDIT: I have found more stuff that doesn’t work!

  • Kazam: exists, but not for Fedora. Possibly unmaintained. I tried pip install kazam, it gives a packaging error.
  • SimpleScreenRecorder: Apparently also X11 only. Saved video files are empty.

All of these have in common that as soon as a recording is started, the app window is hidden, as are controls for stopping the recording. Only Peek has a key combo for it, the others require bringing the app window back before the recording can be stopped.

What do you use for screen recording? Any luck doing what I want to do?

  • Wayland
  • KDE Plasma session
  • with audio
  • single window
  • with mouse pointer

system info:

System:
  Host: golem-fdr Kernel: 6.7.3-200.fc39.x86_64 arch: x86_64 bits: 64
    compiler: gcc v: 2.40-14.fc39 Desktop: KDE Plasma v: 5.27.10 Distro: Fedora
    release 39 (Thirty Nine)
Machine:
  Type: Desktop System: Micro (HK) Tech product: HX80G v: N/A
    serial: <superuser required>
  Mobo: Shenzhen Meigao Equipment model: F6BBA serial: <superuser required>
    UEFI: American Megatrends LLC. v: 0.22 date: 12/13/2022
CPU:
  Info: 8-core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 0 cache: L1: 512 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 895 high: 2739 min/max: 400/4463 cores: 1: 1397 2: 2001
    3: 400 4: 400 5: 1397 6: 400 7: 400 8: 400 9: 1397 10: 400 11: 400 12: 400
    13: 2739 14: 1397 15: 400 16: 400 bogomips: 102208
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] driver: amdgpu
    v: kernel arch: RDNA-2 bus-ID: 03:00.0
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel arch: GCN-5 bus-ID: 07:00.0 temp: 42.0 C
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,radeon,vesa dri: radeonsi gpu: amdgpu,amdgpu
    resolution: 1920x1080
  API: EGL v: 1.5 drivers: radeonsi,swrast platforms:
    active: gbm,wayland,x11,surfaceless,device inactive: N/A
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.5 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon RX 6600M (radeonsi navi23 LLVM
    17.0.6 DRM 3.57 6.7.3-200.fc39.x86_64)
  API: Vulkan v: 1.3.268 drivers: radv,llvmpipe surfaces: xcb,xlib,wayland
    devices: 3
Network:
  Device-1: Intel Ethernet I226-V driver: igc v: kernel port: N/A
    bus-ID: 04:00.0
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 1c:83:41:32:b7:c3
  Device-2: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel
    bus-ID: 05:00.0
  IF: wlp5s0 state: down mac: 8a:08:90:e7:63:6a
Drives:
  Local Storage: total: 1.82 TiB used: 495.46 GiB (26.6%)
Info:
  Processes: 557 Uptime: 3h 17m Memory: total: 16 GiB note: est.
  available: 15.04 GiB used: 9.08 GiB (60.4%) Init: systemd
  target: graphical (5) Compilers: N/A Packages: 92 note: see --rpm
  Shell: Bash v: 5.2.26 inxi: 3.3.31

This is my go-to under Wayland, give it a try, hopefully it meets most of your requirements it looks like it should. It works under Wayland and it’s dead simple to use. Also, there is OBS Studio as well, but it’s a bit more complicated to setup, but also works under Wayland too.

1 Like

There is another called simplescreenrecorder that is in the rpmfusion-free repo and works well.
Can be used for full screen or set to record a rectangle on the screen .

1 Like

Have you tried OBS Studio? I use it and works pretty good for both recording and streaming

2 Likes

I second that. Auto-configuration wizard in OBS Studio help determine the best settings for recording or streaming. The wizard opens up when you load OBS for the first time.

I use it to record workshops and tutorial videos. You have tons of resources in YouTube to get started.

Screenshot_20240212_091945