Need help with screencaster

I’m running fully updated F31 on a Lenovo M53 with a i5-4570 CPU. I’ve been trying out screencasters. My need is to make demo videos that I can distribute as files rather that stream live or place on the web.

I tried the built in Gnome screen recorder (Ctl+Alt+Shift+R) and it did work. However, it doesn’t record audio and and it stops after 30 seconds I found where that can be changed, but my demos won’t be fixed length or brief. I need audio So that one won’t work for me.

I have also tried Peek, OBS Studio, Simple Screen Recorder, and Vokoscreen. They all present the same major problem. When the file is played back, in all cases played with Videos, I get the audio, but the video is solid black.

I have all the codecs loaded and can play videos from other sources using Videos. I have tried having the screen recorders save the recording as different video file types but I always get the same result.

I’m guessing that there is something I need to configure in Gnome or Fedora, but I don’t know what. Any help will be appreciated.

Have a Great Day!

1 Like

Hi @tablepc welcome to the community!

It sound a problem of codecs, than you have codec to reproduce video doesn’t meant than they can encode. Sometimes when one does select the code of output to the transcription select one than is not usable for the system although one can select it.

You can try install from rpm fusion the package ffpmeg or others encoders

If you continue with the same problem, you could try VLC what one can record screen or streaming from rpmfusion too.

I Would like help you more but i have not enough experience with screen recorder or streaming. My last video was with VLC 1 year ago and barely remember than i need do but one thing was that i did select wrong codec under the recording.


From display manager gdm switch to Gnome on xorg.

Hi @youssefmsourani

Wayland seems to be the problem. When I run under Gnome xorg the video and audio work fine. I guess I have a an issue to write at GitLab unless it’s already been written. Do you know if an issue has been written on this?

1 Like

Is a known problem, in wayland the program need screencasting by using gnome api/dbus and not directly from gstreamer or ffmpeg.

There are other ways that are not yet clear.
Such as using flatpak portal and pipewire.

did you try last version of OBS Studio from flathub ?

(google translate)

1 Like

Sorry for taking so long to reply. My microphone quit and I had to get another one before I could really try it out. The Great news is that the OBS Studio from the flathub repository works great. This was my first install of a flathub package, but it went very smoothly and the application works great. Thanks for your help. Now I can start making the videos.

1 Like

Simple, with the power of ffmpeg…

 ffmpeg -f x11grab  -s 1366x768 -i :0.0 -r 25 -vcodec libx264  output.mkv


 ffmpeg -f x11grab  -s 1024x768  -i :0.0 -r 25 -vcodec libx264  output.mp4

With Audio

ffmpeg -f x11grab -s 1366x768 -i :0.0 -r 25 -f pulse -ac 2 -i default -vcodec libx264 output.mkv