Choppy video playback Intel HD

i find this kind of weird, but maybe it isn’t weird at all. On my MacBook I have no issues with playback, but on my Mac Mini I do. Both are running Fedora 36 Worksation.

Both were running Workstation 35 before and now the only difference with the installations are that i upgraded from Worksation 35 to 36 on my MacBook but installed Workstation 36 from scratch on the Mac Mini.

Hardware-wise the MacBook has a Intel Iris 5100 while the Mac Mini has a Intel HD 3000. Of course there are performance differences between them, but what makes me ask for help is that I didn’t notice any lagging in video playback while I was on Workstation 35.

I have searched forums with similar problems and compared installed drivers between the computers, but nothing really seems to make any difference.

I have also noticed some artefacts being created when you scroll a list fast, like a sidebar with entries… So maybe this isn’t video playback related.

What are you using for video playback? Which desktop environment?

I am on Gnome 42, so I am guessing gstreamer…? The players are Stremio, Celluloid, Clapper and Gnome Videos. They all act the same now with this choppy playback. Historically whenever I have had any codecs issues Celluloid has always worked flawlessly, so it doesn’t seem to be a codec issue.

GNOME Videos uses gstreamer, but Celluloid uses mpv-libs (which in turn uses ffmpeg). I’m not familiar with any of the other players. Can you reproduce the choppy playback if you start your GNOME session on X11 instead of Wayland? Can you verify that playback is choppy when playing videos encoded with different codecs (e.g. VP9, AV1, H.264, H.265)? Can you post terminal output of mpv playing these videos?

I tried it with Gnome X11 and it was pretty heave screen tearing when playing videos, which is why I prefer Wayland :grin:At first I thought it was 1080p x265 which was too heavy but I have played x264 as well as 720p and they are all choppy.

Maybe it really is the hardware… I was thinking of reinstalling macOS on it to see how the videos look there. But I’ll run the terminal tests you asked for first

[hackan@Mac-mini ~]$ mpv '/home/hackan/Video/The.Orville.S03E01.1080p.HEVC.x265-MeGusta[].mkv' 
 (+) Video --vid=1 (*) (hevc 1920x1080 23.976fps)
 (+) Audio --aid=1 --alang=eng (*) (eac3 6ch 48000Hz)
 (+) Subs  --sid=1 --slang=eng (*) 'English [SDH]' (ass)
[vo/gpu/wayland] GNOME's wayland compositor lacks support for the idle inhibit protocol. This means the screen can blank during playback.
AO: [pulse] 48000Hz 5.1(side) 6ch float
VO: [gpu] 1920x1080 yuv420p10
(Paused) AV: 00:03:19 / 01:09:57 (5%) A-V:  0.000

Exiting... (Quit)

I am not sure if it is possible to get a more verbose/extensive terminal output…
But to make it more clear, the choppieness happens when there are like big redraws in the scene. If it is like a closeup of two people talking for example then the video is smooth. And it doesn’t seem to matter if I have the video in fullscreen or if I make it into like a half-sized window.

It looks like mpv is not using hardware accelerated decoding. That might explain the choppy playback.

Well that’s interesting… I was so sure that Intel + Wayland was like working out of the box. Should I maybe remove all the drivers and just use what’s inside the kernel?

Looks like the video you are trying to play is 10bit. Does your hardware support 10bit video decode?

How do I check that?

See this table here: Intel Quick Sync Video - Wikipedia

For hardware decoding, although these instructions are for Firefox, the dependencies you solve there will empower desktop players as well: Firefox Hardware acceleration - Fedora Project Wiki

mpv doesn’t use hardware acceleration by default. You need to enable it explicitly on the command line: mpv --hwdec=vaapi or put hwdec=vaapi in $HOME/.config/mpv/mpv.conf.

vainfo command output will show supported codecs.