X265/x264 playback

Hello, I’ve just switched to fedora38 silverblue and I’d like to be able to play x264/5 videos on my i5 6th gen using mpv/celluloid in flathub flatpak. VLC works fine but I prefer the other two.

Spoiler: It doesn’t work out of the box but I’ve noticed some strange differences when running using root.

If you flatpak run io.mpv.Mpv with your user you get this log and it runs very choppy:

 (+) Video --vid=1 (*) (h264 1920x1080 23.976fps)
 (+) Audio --aid=1 --alang=jpn (*) (aac 2ch 44100Hz)
 (+) Subs  --sid=1 --slang=eng (*) 'English subs' (ass)
[vo/gpu/wayland] GNOME's wayland compositor lacks support for the idle inhibit protocol. This means the screen can blank during playback.
[vo/gpu] VT_GETMODE failed: Inappropriate ioctl for device
[vo/gpu/opengl] Failed to set up VT switcher. Terminal switching will be unavailable.
[vo/gpu/opengl] Failed to get EGL display.
[vo/gpu] Failed to setup EGL.
[vo/gpu/wayland] GNOME's wayland compositor lacks support for the idle inhibit protocol. This means the screen can blank during playback.
MESA-INTEL: warning: ../src/intel/vulkan/anv_formats.c:764: FINISHME: support more multi-planar formats with DRM modifiers
AO: [pipewire] 44100Hz stereo 2ch floatp
VO: [gpu] 1920x1080 yuv420p
AV: 00:00:01 / 00:23:40 (0%) A-V:  0.363 Dropped: 9

While running under root user video is fine but there is no audio… (I know it shouldn’t be done)

[mpv_inhibit_gnome] Could not load SO plugin /app/etc/mpv/scripts/mpv_inhibit_gnome.so
 (+) Video --vid=1 (*) (h264 1920x1080 23.976fps)
 (+) Audio --aid=1 --alang=jpn (*) (aac 2ch 44100Hz)
 (+) Subs  --sid=1 --slang=eng (*) 'English subs' (ass)

(process:2): GLib-GIO-CRITICAL **: 09:02:28.716: g_dbus_connection_emit_signal: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(process:2): GLib-GIO-CRITICAL **: 09:02:28.816: g_dbus_connection_emit_signal: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
[ao/pipewire] Could not connect to context '(null)': Host is down
[ao/jack] cannot open server
[ao/sdl] SDL_Init failed
[ao] Failed to initialize audio driver 'sdl'
Could not open/initialize audio device -> no sound.
Audio: no audio
VO: [gpu] 1920x1080 yuv420p

It must be some fedora issue related to permissions.

How is possible that a system such as fedora has these issues out of the box?

Fedora comes without the different codecs. You have them to install separately. Did you do so?

Do you mean using rpm-ostree or install separately some other optional flatpak dependency?

Btw I don’t want to use rpm-ostree and install bits and pieces. I’m trying to use only flatpak.
If I need to do that to view a simple video I’m going back to my Arch or Gentoo :smiley:

Please check the “Software” program, on the workstation i do have on the first page “Explore” additional options to install. You will find them on the bottom of the "Explore"page, named “Other Categories” “Codecs”. Do you see them in Silverblue too?

About the codecs, they not come preinstalled because they are not all opensource and free.

Yeah I see some codecs,
I’ve added the h264 but unfortunately it doesn’t help. I’m actually trying to play HEVC videos.

Do you have more options than these?

That probably will require the libheif-freeworld package from rpmfusion.

AFAIK you will not be able to play a lot of the media with various fedora unsupported codecs unless you are willing to install those codecs as rpms on your system. Almost all that are available can be installed from rpmfusion.

1 Like

Btw I’ve solved the issue using a toolbox and exporting a desktop file manually.

The solution you are proposing involves in installing stuff in the host system but I wanted to have either a flatpak (I’ve used the flathub one) or a container of some kind. I know that adding layers on silverblue is discouraged.

The flatpak works under other systems. Specifically on my fedora silverblue install there’s some kind of permission issue.