Choppy/freezing video


I’m experiencing freezes in the video when playing video.
I get this when using Youtube on Chrome or Firefox and I also tried downloading some AVI file to the desktop and got the same result.
I have a P1 Gen2 and installed the Nvidia drivers. I’m using Xorg and not Wayland (Nvidia says it’s not safe I understand).
As for the kernel I had to downgrade to 5.1.20 because 5.2.x (6, 7 and 9) prevented my computer from suspending properly.


Do you have Force Full Composition Pipeline enabled in the nvidia driver settings? If so, can you try disabling it?

Thanks for the answer but it was disabled

Can anyone help with this?

Out of curiosity, do you have any GNOME extensions enabled?

Sadly I’m not too familiar with nvidia, and it also has a reputation for being rather finnicky in general, so it’s hard to really have a concrete solution right now…

Here’s a screenshot of Gnome Tweaks extensions window. Think any of these might do it?
I’m new to Linux in general but I think at one time I enabled an extension that showed the seconds of the current time and it caused higher CPU usage so you may be right…

Can you post the output of the following commands ?

lspci -k | grep -i -A3 "vga"

sudo lshw -c display

glxinfo -B

It can be some issue with nouveau and the privative driver. How did you install the Nvidia driver, via gnome-software? Is nouveau in the blacklist?

cat /etc/default/grub

Do you cpu be an integrated graphic card from intel?

The information that you can provide maybe can help to the comunity to find a solution.


00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile) (rev 02)
Subsystem: Lenovo Device 229f
Kernel driver in use: i915
Kernel modules: i915

01:00.0 VGA compatible controller: NVIDIA Corporation TU117GLM [Quadro T1000 Mobile] (rev a1)
Subsystem: Lenovo Device 229f
Kernel driver in use: nvidia
Kernel modules: nouveau, nvidia_drm, nvidia

description: VGA compatible controller
product: TU117GLM [Quadro T1000 Mobile]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:185 memory:ed000000-edffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:3000(size=128) memory:ee080000-ee0fffff
description: VGA compatible controller
product: UHD Graphics 630 (Mobile)
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 02
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=i915 latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
resources: iomemory:600-5ff iomemory:400-3ff irq:140 memory:6040000000-6040ffffff memory:4000000000-400fffffff ioport:4000(size=64) memory:c0000-dffff

name of display: :1
display: :1 screen: 0
direct rendering: Yes
Memory info (GL_NVX_gpu_memory_info):
Dedicated video memory: 4096 MB
Total available memory: 4096 MB
Currently available dedicated video memory: 2760 MB
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro T1000/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 430.40
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6.0 NVIDIA 430.40
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 430.40
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

GRUB_DISTRIBUTOR=“$(sed ‘s, release .*$,g’ /etc/system-release)”
GRUB_CMDLINE_LINUX=“rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=/dev/mapper/fedora_localhost–live-swap rhgb quiet”

My machine is a Lenovo P1 Gen2, it has an integrated display adapter and an Nvidia one


It looks right to me except for the drivers version

430.40 This one looks like that is not supporting the Quadro T1000 Linux x64 (AMD64/EM64T) Display Driver | 430.40 | Linux 64-bit | NVIDIA

435.21 This one is supporting the Quadro T1000

I have not one nvidia card so I can not ensure at It “can be” the cause of your problem. You can wait until it gets upgraded.

Maybe someone knows and can help you to change temporaly at intel driver and so can confim it is a nvidia driver issue.

You can try run chrome or firefox with hardware accelaration off (disable) to try see if it help temporaly.

Edit: Check what you have installed this packages to enable video acceleration support for your player

vdpauinfo libva-vdpau-driver libva-utils if it is not installed , you should install them

dnf list --installed {vdpauinfo,libva-vdpau-driver,libva-utils} if they are not installed you can install them with the command

sudo dnf install {vdpauinfo,libva-vdpau-driver,libva-utils}


Thanks for the answer.
You are right, my driver indeed doesn’t support the card, that’s probably the problem.
However, the RPM Fusion repo (Nvidia) from which I installed the driver doesn’t seem to contain the vesion I need.

Do you think it’s still worth installing the vdpau utilities you mentioned?

I am sure the update is coming soon. I recommend wait for the update.

If you dont use a video player what do use of this like VLC surely is not.