Anaconda in the KDE Spin should appear native

Using https://download.fedoraproject.org/pub/fedora/linux/releases/test/40_Beta/Spins/x86_64/iso/Fedora-KDE-Live-x86_64-40_Beta-1.10.iso, kcmshell6 kcm_style hasn’t been configured to set breeze-gtk as the default GTK theme, meaning that Anaconda uses the default GNOME 3 theme - Adwaita Light. Additionally, it displays fullscreen, preventing the user using the live USB image whilst it is open.

Were we to instead invoke it without the fullscreen preference at true, it would display as a regular window (I’ve tested this, and it dynamically adjusts correctly in every view I evaluated). Additionally, were we to set kcm_style as aforedescribed, it would appear as any native Qt program would.

Try these for yourself - press F3 when the Anaconda window is active (or set a KWin rule if you’re weird) and disable fullscreen, then set the Breeze theme as the GTK theme. It looks a lot more inviting and less like it’s been hacked onto the image.


I intend to file a Log in to Red Hat Bugzilla about this, because it should be so trivial to remediate for as much advantage as I’ve described.