An Error During ( sudo dnf update ) packages

im trying to update all process going well but i have a problem with just this package
and this the terminal ;

(base) naeem@fedora:~$ sudo dnf update

Copr repo for openvpn3 owned by dsommers        172  B/s | 341  B     00:01    
Errors during downloading metadata for repository '':
  - Status code: 404 for 

Error: Failed to download metadata for repo '': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
Ignoring repositories:
Last metadata expiration check: 0:04:57 ago on 2023-11-05T20:12:03 EET.
Dependencies resolved.
Nothing to do.
Complete! will list the directories that are present. It (currently!) lacks fedora-39-x86_64. Upstream for the openvpn3 copr is:
Community OpenVPN and has a table showing availability of openvpn3 packages for various distros has footnotes:

Fedora Rawhide is a moving target and there will be periods where there will not be updates available until we sort out the required changes to the build environment.

Fedora 38 and newer and Ubuntu 23.04 and newer are still not available in stable release. A development release is being worked on.

There are other VPN packages in Fedora 39.

1 Like

Is there some way to fix this or should I wait for an update or what + I updated to Fedora 39 before releasing it

You could just wait until then, or use another vpn as @gnwiii pointed out, that are packaged in Fedora’s repos.

1 Like

look idk am i fix it or not but i did that and its worked the error not appears any more !
i removed the copr

cd /etc/yum.repos.d/
root@fedora:/etc/yum.repos.d# ls
brave-browser.repo microsoft-edge-beta.repo
cloudflare-warp.repo microsoft-edge.repo rpmfusion-free.repo rpmfusion-free-updates.repo rpmfusion-free-updates-testing.repo
fedora-cisco-openh264.repo rpmfusion-nonfree-nvidia-driver.repo
fedora.repo rpmfusion-nonfree.repo
fedora-spotify.repo rpmfusion-nonfree-steam.repo
fedora-updates.repo rpmfusion-nonfree-updates.repo
fedora-updates-testing.repo rpmfusion-nonfree-updates-testing.repo
google-chrome.repo vscode.repo
librewolf-repo.repo winehq.repo
root@fedora:/etc/yum.repos.d# rm
rm: remove regular file ‘’? y
root@fedora:/etc/yum.repos.d# sudo dnf update
Last metadata expiration check: 0:04:29 ago on 2023-11-09T13:25:54 EET.
Dependencies resolved.
Nothing to do.

edit : Repo files are stored in /etc/yum.repos.d/, coprs start with “_copr”. Just delete correct file and it work for me