A bit of a mess of boot images: three present, only the oldest works


Quick background: I’m a Linux user since the '90s, mainly Slackware. I year ago I started using Kubuntu and kept with it for a year. I was generally pleased and, most important for me, nothing ever broke on normal upgrades.

A few weeks ago I switched to Fedora out of long-standing curiosity and having found Arch too unstable (and unfriendly).

I’m mighty pleased with Fedora, and also love the server version which I installed on my Pi. (Fancy browser interface even, though I’m mainly cli.)

Unfortunately, today I performed the standard sudo dnf upgrade and my system started acting quirky. I’m working in R Studio and the math stopped rendering in my notebook editing panel and my terminal window had bg/fg colors reversed where actual text was displayed.

I rebooted my system (6.1.18-200) and I had also lost HDMI output, and it hung after grub with no error messages. I then tried to boot an older version, 6.1.15-200, which booted fine and HDMI was back, BUT, no wifi. Then I tried the 6.1.18 again and I had HDMI back but still hanging after grub with no errors displayed.

I had a third image available, 6.0.7-301, which worked and in which I’m working now. The glitches in R Studio have gone away and I’ve got HDMI and Wifi back.

As a note, all software on the system has been installed with dnf or flatpak in a few cases.

So I’m looking for advice on how to proceed.

  1. I’d like to be using the newer version and understand why the image isn’t working. This is my priority. To that end, should I try to diagnose the bad image(s) from my running system? Should I try to diagnose from a live usb stick? Can I just generate new images to replace the bad ones?

  2. I’m concerned about stability of system upgrades. After so long with Slackware I am not used to breakage on regular system updates/upgrades and did not experience this in Kubuntu either. I guess I’m asking what my expectations should be around this. How often do users experience problems after upgrades? I can handle the occasional issue, but not if they are frequent.

I have been using fedora for many years. Presently I am using 2 desktops and one laptop (dual GPU) all with nvidia GPUs and have had no errors of any kind with updates or version upgrades on any.

I never use the gui to do updates. I only use dnf.

You did not state anything specific about the hardware so please post the output of inxi -Fzxx so we can tell what the hardware is. It also will tell us what drivers are in use.

In my experience, the quality of hardware support highly depends on the manufacturer and specific model.

Some hardware can work OOTB with regular updates for years, while other may require custom patching for each major kernel release.

It’s common practice to file a ticket or subscribe to the existing one on the related bug tracker and stick to the working package version while waiting for updates.

You can also help with testing updates and providing feedback.

Thank you for your reply. I’m consoled to hear your great experience. I hope to have one as well. I’m concerned if it is a “hardware issue” because that would imply a regression bug introduced by a system update which shouldn’t happen. I’m going to start from the working image and go from there I think.




Just so I’m clear, you suggest I file a bug report and then stick with the working version until I get a response? (I’m just learning my way around the Fedora ecosystem.)

I’m frankly a bit dismayed to suddenly have a hardware issue on an upgrade after using various Linuxes on the computer for a year and a half or so. And since everything works again back in the old version and this is not an old computer I think that hardware failure is unlikely.

With regard to the boot failure in the newest version it seems that the initrd could be messed up. I would normally mount and chroot into the image and re-build the initrd. I imagine this would be the same procedure for Fedora?

Thanks for your help,


1 Like

There are a couple factors that end up causing issues with upgrades. License restrictions prevent Fedora from distributing firmware for some devices, and vendors are often slow to make changes needed by current kernels, so even if you have drivers from non-Fedora sources, they can fail when you apply an update.

Features like display brightness control, particularly for laptops where the control has been different for every vendor, are being revised to focus on standardized interfaces, but this may require BIOS updates so may never work on older laptops or all-in-one systems.

I have experienced transient issues with display colours and brightness and also wifi on an old iMac with Nvidia graphics. With the latest update Fedora tried to load the same firmware with a different name, (easily worked around with a symbolic link, not so easy to determine if it is a bug or a lag correcting a mismatch between driver and firmware versions that will get fixed in time).

I expect these issues with any distro that provides recent kernels. I use Fedora to help detect problems in my software, some that uses Rstudio, and to ensure that I stay onside with SELinux. For a number of years I was playing catch-up with changes in Linux libraries. Recently my software has not needed changes, but I’m watching a couple elderly libraries that should be replaced with newer and more capable libraries.

1 Like

That’s it, and try to find and subscribe to already submitted relevant bug reports as they often include useful comments from other users and devs to apply possible workarounds or install early updates from the testing repo.

You can regenerate initramfs like this:

sudo dracut -f --regenerate-all

See also: dracut(8) — Arch manual pages

Thanks very much.

Get BlueMail for Android

Thanks for taking the time to write this. I appreciate the information since I’m new to fedora.

I have been experiencing some glitches, mainly some lively screen remnants and problems with the menu bar of windows sometimes which I assume are all related to plasma since I’ve seen this in the past and so have used X11 which is Kubuntu’s default. Since plasma is Fedora’s default I wanted to stick with it and the issues are minor. I assumed that that was why I was having these video glitches after the upgrade but then I realized I couldn’t do a ‘file/save as’ as it couldn’t load the directory! And alacrity couldn’t read it’s config file. So I’m thinking kennel upgrade issues not just video/plasma/Nvidia. So that’s the image that hangs on boot and which I need to poke around in.

Anyway I appreciate your input. Cheers.


I guess it’s time to get to learning about btrfs and the rollback functionality.

Get BlueMail for Android