Fedora 35 and Discover woes


A couple of weeks ago, I upgraded a Fedora 33 to 35 using the normal upgrade process, and this went fine. I’ve done this procedure several times on multiple PC’s, and it’s just brilliant how well the upgrade works. However, from that time, when I clicked the package update popups, Discover opened instead of the until then usual tiny system tray thing, which would only show the package names that would be updated.

Yesterday, Discover wanted to “upgrade” my Fedora 35 to… 35 for the umpteenth time. This was suspicious, since I was already at 35. However, since Discover kept asking, I thought, “well, let’s go for it”. That was the wrong choice. After updating and rebooting, Fedora showed a distorted login screen telling me it could not load some .so file (sorry, I didn’t take any pics, and I don’t remember the exact message), but I could still type the password. After I typed the password, hoping to fix the problem when logged in, the system would just freeze and respond to nothing. To shorten the story, in the end, I had to reinstall Fedora from scratch.

To me, Discover is a piece of software that is slow to start and use, has too many bells and whistles to simply update packages for which an update is available (the old way was fine; there are other ways to notify a user that a reboot after updates is needed), and since it completely broke my Fedora I find it plain dangerous. Unless I really have to, I will not use Discover again: I hate having to reinstall Fedora when it wasn’t needed in the first place.

I think Fedora is mostly used as a desktop OS. I do on several PCs for quite some time now. But as much as you think you backed up every config file there is (not everything is in the user profile, which is on a separate volume, so yes, I salvaged that), you’ll always miss something, and it takes a lot of time to get to the same spot as before Discover broke things.

Although it looks like it, I do not want to rant; instead, I wanted to inform about what happened and what shouldn’t have happened. Converting this into a question/request: please fix Discover, so it doesn’t break the OS. Running “dnf update” usually doesn’t, so why should Discover?

Thanks for the post. Discover should not really break your system. It uses packagekit underneath (which you can also use via the pkcon command line tool`) so it doesn’t really do anything special. I’m not entirely sure why it asked you to update F35 to F35—was it suggesting an upgrade, or was it just the regular “offline update” mechanism?

With both Discover and Gnome software, their metadata can sometimes be inconsistent if one is also using dnf, because packagekit and dnf do not share their caches and metadata state. I tend to only use dnf, and I completely ignore both Gnome Software and Discover—but to keep them in sync, I run pkcon refresh force from time to time.

Note also that if you’re happy using dnf, you can just stick to it and turn off upgrades (I know Gnome Software allows us to turn off both automatic updates and notifications, so I expect Discover would have this too).

Please do note what errors you get if possible, because without those we can’t file bugs and so they cannot be fixed—developers just don’t have enough to go on.

I’m using the KDE spin, but I get the idea.

If at the time I had a working crystal ball and could have foreseen what would happen, then I’d have made screenshots and photo’s from the login screen. :wink: But without kidding, I didn’t do any of that because I didn’t expect things to break like this, so I have to dig from memory. And memory says that it actually wanted to upgrade, which really surprised me. It for sure wanted to install a lot of F35 labeled packages, which were or should already have been installed. But I can’t be of help more than this, which I realize is no help at all, because I don’t have any hard evidence to show.

Yes, I can stick to dnf, but I’ve been happy with that system tray app (I actually don’t know which package that is coming from, but the PC I’m working on now has that system tray app) which alerts me for pending updates and always just worked, reports when it’s done, and leaves the decision to reboot to me.

1 Like