Zram0 reboot hang - Fedora 36

February of last year I attempted to upgrade from 36 to 37. The reboot would just hang indefinitely. I uninstalled the upgrade to 37 and was able to continue using 36. The issue is unresolved here: Upgrade F36 to 37, hangs on boot, zram0 issue

I have continued to use Fedora 36 since then (until now with no issues). Recently when running wine, the system froze, so I hard rebooted. Now when trying to boot into Fedora 36 I get the same error message as when I tried to boot into either Fedora 37 or the rescue option. Here are the last few lines from booting:
[OK] Started rpc-stated-notify.s…m-Notify NFS peers of a restart.
[TIME] Timed out waiting for device (there are 2 squares) dev-zram0.device - /dev/zram0.
[DEPEND] Dependency failed for dev-…m-Compressed Swap on /dev/zram0.
[DEPEND] Dependency failed for Created swap on /dev/zram0.

v 6.1.13 is the kernal I was able to use that past 14 months, where v 6.1.14 is the kernal that was installed with Fedora 37.

I would like to rescue some of the data from the disk. The easiest way might be to figure out how to boot into F36.

Is it possible that the zram issue is hardware related (failed motherboard or hard drive) rather than software related? z is the drive that contains the Fedora installation.
The reason I have not upgraded is that my dvd drive is not powering up (as though it were disconnected) and even though I have it set in my BIOS to boot from a USB memory stick (which is an option for Fedora installation), my computer ignores this and boots the later option instead, which is the hard drive.

To be clear, the 2 questions I have are:
Is the reboot hang a hardware issue?
What steps do I need to take in order to reboot back into Fedora 36, and if unable, how to copy some folders from that installation to another drive?

I have experience with DOS in the past, but haven’t needed to operate outside of a OS very often. Please be detailed as to what to type or keys to press etc.

I know this will not help you now, but Fedora 36 is absolutely outdated and you should have updated much earlier. A Fedora release cycle is relatively short and even Fedora 37 is already outdated and for security reasons you should upgrade as soon as possible to the latest version – not waiting for software to break.

See Fedora Linux | endoflife.date

I recognize, you are currently trying that and have no solution for your apparent problem, but this just FYI. In the worst case, just install a fresh new version depending on whether that is feasible…

Zram is the swap space created within your memory. If you have memory issues it is a hardware problem.

Please create a F39 or F40 Beta USB stick and check if you still get the zram error.

It should look like this if you boot correctly and the ztram is working fine:

[  OK  ] Created slice system-systemd\x2dzr…- Slice /system/systemd-zram-setup.
         Expecting device dev-zram0.device - /dev/zram0...
[  OK  ] Found device dev-zram0.device - /dev/zram0.
         Starting systemd-zram-setup@zram0.…vice - Create swap on /dev/zram0...
[  OK  ] Finished systemd-zram-setup@zram0.service - Create swap on /dev/zram0.
         Activating swap dev-zram0.swap - Compressed Swap on /dev/zram0...
[  OK  ] Activated swap dev-zram0.swap - Compressed Swap on /dev/zram0.

You can check this wile booting and pressing the ESC key.

This you should be able to do also with the live Iso USB. If you use Gnome for example you can open the Files app and click on “+Other Locations” there you should see the installed and mounted partitions … if it is a default installation it would show some “Fedora Linux” share where you can find your /home/username to backup the data …

1 Like

Hello @connor84 ,
Welcome back to :fedora: !
To get around this you can create a swap partition on your HDD/SSD to use for swap instead of the Zram swapfile. You can do this with the bootable kernel that you already have installed. You use Gnome Disks, found in Utilities to look at your storage devices. If you installed to one physical device, you can shrink your existing partition that is at the end of the device, then you will need to resize the btrfs filesystem. It is a good idea to install btrfs-assistant first to make the btrfs actions easier, since there are things to do after resizing that involve some file maintenance steps.
Steps …

  1. Shrink desired partition with Gnome Disks (very likely a BTRFS subvolume), you can do this very easily in a terminal too
  2. Create Linux Swap partition on newly available space
  3. Resize BTRFS filesystem on resized partition (likely subvolume in this case)
  4. Turn off Zram swapfile and turn on Swap partition you created in step 2.

As mentioned:

If you have memory issues it is a hardware problem.

Use memtest86+ v7.00 to test the memory. Note that some transient errors may not appear for many hours or even days of testing.

1 Like