Upgrade F36 to 37, hangs on boot, zram0 issue

I originally installed F33. Years later I upgraded to F34, and then immediately to F36. Fedora ran fine for about a year. Now I upgraded from F36 to 37. Each time the upgrade was done via command line in terminal.

The commands I entered were:

sudo dnf upgrade --refresh
sudo dnf install dnf-plugin-system-upgrade
sudo dnf system-upgrade download --releasever=37
sudo dnf system-upgrade reboot

The plugin was unnecessary as it was already installed.
I am running Cinammon if that matters.
Also, after the F33->34->36 upgrade, the boot screen now has some lines that are gibberish. Lines of characters with accents and umlots. Some are repeated, but obviously these are not words.

After the F36->37 upgrade I get an error message during the boot process:
[Failed] Failed to start nvidia-pow…service. - nvidia powrd service

The boot process hangs in 3 different areas:

After the initial upgrade and sudo dnf system-upgrade reboot, the system hung on the line:
starting plymouth-quick-wai…until boot process finishes up…

So I manually rebooted and selected the F37 installation. It hung on the same line again.

So I manually rebooted and selected the F36 installation (from after I had done the sudo dnf install dnf-plugin-system-upgrade). I don’t recall the kernal but it is the same one as the F37 installed, something point 1.
This time it hung on the line following the previous one:
Started rpc-statd-notify.s…m - Notify Nfs peer of a restart.

So I manually rebooted and selected the F36 installed (from before I had done the sudo dnf install dnf-plugin-system-upgrade). I don’t recall the kernal but is the same as the F37 installed, except point 0.
It hung on the same line repc-statd etc.

I was dismayed to find that I could go back to my F36 install after the failed F37. Even when booting from either version of F36, watching the output it eventually says Welcome to F37!

Okay but we have one more resource to try. I booted into the Fedora rescue (which says it is F33). This time it was able to go one extra line beyond the previous:
[Time] Timed out waiting for device driver zram 0.device - /dev/zram0.
[Depend] Dependency failed for dev-…m - Compressed Swap on /dev/zram0.
[Depend] Dependecny failed for syst…e - Create swap on /dev/zram0.

As all previous installations have gone flawlessly and I have a giant HD. I did not backup anything. :confused: I didn’t set it up to block other accounts from accessing my data, so hopefully if I have to do a reinstall I am able to access the data first and put in on an external drive.

I have 32 GB ram. Watching the resource monitor, I have never seen it use more than 8GB for anything. From memory, I have between 1 - 1.5TB free space on the HD. The puter is ~7 years old. So I wouldn’t expect a hardware issue.

Any ideas on how to solve this zram0?

Also can I boot from a stick after downloading the iso:
Download Fedora Cinnamon Desktop

I’m thinking that I can rescue my data this way if I have to do a re install.

This is not an error. Simply an information message.

What did you consider hung? 1 minute? an hour? more?
You said that it finished booting and said Welcome to F37! which to me indicates it did complete the upgrade even though you were booting with an F36 kernel at that time.

Have you tried booting the F37 kernel and patiently waiting for everything to load and the boot to complete? The fact the message appeared with an F36 kernel is encouraging.

Booting with the rescue kernel seems a bit counter productive since it is that old in relation to the current kernels and fedora did not have gnome 40+ until fedora 34 was released…

This indicated it was waiting for something to complete before the boot finished, and an interruption may have caused corruption.

The simplest fix I could suggest at this point may be to boot into the F36 kernel. (complete the ‘welcome’ steps as you wish), then do cat /etc/fedora-release to see what version the system actually believes it is.

If it returns as fedora 37 then potentially you may be able to solve the boot problem with 37 by doing

  1. dnf list installed kernel to see what exact kernel info is related to the 37 kernel. I have kernel 6.1.13 so that gives me kernel version 6.1.13-200.fc37 installed.
  2. dnf remove kernel*6.1.13-200.fc37* would remove all kernel packages related to that kernel version.
  3. reboot to allow the system to know that kernel is no longer installed.
  4. dnf upgrade --refresh to reinstall the latest kernel and to verify everything else is fully up to date.
  5. reboot again to use the f37 kernel.

This should work and ensure the latest kernel is working.

It would say Welcome to F37! and then it continues to load more things as shown on the output screen. It didn’t hang on the Welcome line. There are many lines after that that continue the boot process.

I cannot boot into any kernal. I listed where it hung at each boot option. Did you mean to access the console after attempting a boot (and it hanging)? What was the key command to access the console during the boot process again?

After the initial install I waited 30 minutes while it hung on the same line. The other boot options I tried, I waited 10 minutes each time.

You can try interrupting grub, and adding systemd.zram=0 to the kernel parameters.

that should disable zram.

I tried thie zram0 thing, but it still hung.

I was able to access the terminal after it had said Welcome to Fedora 37 and it was just hanging (ie: no login screen). When I list installed kernel, it is the same one as yours, but it says @ updates.

When I do the dnf remove kernel command (which I had to sudo to do) it says:

Error:
Problem: The operation would result in removing the following protected packages: kernel-core

So it does not allow me to remove it. :confused:

You cannot remove the kernel that was booted.
The command uname -a will show the booted kernel.

After it hung again, I tried doing an update via sudo dnf upgrade --refresh (without first removing the kernel). It downloaded and installed the updates for 6.1.14 but it still hung (I left it for many hours) at:

Started rpc-statd-notify.s…m - Notify Nfs peer of a restart.

I am unsure how I would boot into a f36 kernel since even though it says f36 as one of the options in the GRUB, booting that option, the kernel shows as f37.

Also, using the F37 installation disk, I am unable to access the files under my user name. So I sure need to fix this rather than just do a reinstall.

Using the F37 install disk, where do I find my unsuccessful boot logs?

As mentioned in the other topic use the newest F39 and or F40 Beta install disk to move your data:

Ilikelinux mentioned:
This you should be able to do also with the live Iso USB. If you use Gnome for example you can open the Files app and click on “+Other Locations” there you should see the installed and mounted partitions … if it is a default installation it would show some “Fedora Linux” share where you can find your /home/username to backup the data …