Can't upgrade to fedora 36


I have been trying to upgrade Fedora from 35 to 36 without success. I followed multiple times instructions on DNF System Upgrade :: Fedora Docs.

Everything goes well. I run the system update reboot, the computer reboot but nothing happens and and my fedora is still on version 35.

I tried to install using gnome software center but I got the same result, everything seems to go well but after reboot, the computer is still on Fedora 35.

I tried every command I found to clean the dnf cache, but still without success.

Any idea on what could be the issue or how I can discover what is the problem?

When you reboot, are you just doing a normal reboot or are you doing sudo dnf system-upgrade reboot ? The latter should reboot and trigger the upgrade.

1 Like

I do sudo dnf system-upgrade reboot and nothing happens. Any idea of how I can discover the problem?

Did you updated the f35 version before upgrading to f36.

What do you mean with “nothing happens”? Does your computer reboot? If yes (but it looks like it gets stuck), it may be upgrading in background which may take a while (~30…40 minutes on my machine) and reboot automatically after finishing.

1 Like

From the OP, it sounds like the computer reboots but boots normally and not into the dnf upgrade process. I’ve seen this happen before (not recently) when someone has switched between BIOS and UEFI boot.

That’s exactly what happened. I will investigate you suggestion. Do you think a reason may be that I use logical volume groups?

Have you tried when you reboot tapping the shift or the esc key to see if there’s an option where you can choose which kernel to use if there’s an option to upgrade.

LVM shouldn’t be a factor.

@straycat solved the puzzle for me. After countless attempts, I am finally on 36! I didn’t do anything special, just booted after F2 and Fedora just upgraded. Thank you very much for yours and @vwbusguy messages.

1 Like