Upgrade error 33 to 35, dnf system-upgrade not working

I was updating the OS from version 33 to 35, but there was an interruption during the installation.
Now it doesn’t boot normally, only at the prompt, but OS version appears as 35 but kernel still at 33.

Fedora Linux 35 (Workstation Edition)
Kernel 5.14.17-101.fc33.x84_64 on an x86_64

I’m trying to do the upgrade procedure via prompt but the dnf system-upgrade command doesn’t work, even if it’s installed it returns the error

No such command: system-upgrade. Please use /urs/bin/dnf --help
It could be a DNF plugin command, try: "dnf install ‘dnf-command(system-upgrade)’


I checked the etc/dnf/dnf.conf and was without plugins=1 added manually but still does not execute the command.

Any idea how to fixed this problem of system-upgrade? !or some way to downgrade?

1 Like

Please do all steps again. Maybe remove sudo from the statements and use /usr/bin/dnf as the errormessage also mentions it as /usr/bin/dnf

DNF System Upgrade :: Fedora Docs

At first I had duplicate packages between versions 33 and 35, I removed them from version 33 and the system-upgrade worked.

But when I go to do the dnf system-upgrade reboot returns error below.

Error: system is not ready for upgrade.

I made every step of the link, without success. Any idea?


From your pic attached above, I just want to making sure you already did following step:

# Upgrade current system first.
$ sudo dnf upgrade -y

# Install plugin for upgrading the system.
$ sudo dnf install dnf-plugin-system-upgrade

# Upgrade the system version.
$ sudo dnf system-upgrade download --releasever=35

# After above command finished.
$ sudo dnf system-upgrade reboot

Hi Syaifur Rizal,

Yes, I did. But on sudo dnf system-upgrade reboot now I have the error
Error: system is not ready for upgrade.

I believe from that message there should be some packages that is not downloaded properly. But I’m not sure.

Are your current system after above instruction still work as before? Or you stuck on tty thing?

If your system still work as before, maybe you could considering upgrade to 34 first.


Maybe you could check $ cat /etc/os-release to check if you are still on Fedora 33.

1 Like

Please take a look at: Wine installation get "file conflict with dependencies" error - #6 by vgaetera

ref: DNF System Upgrade :: Fedora Docs

1 Like

The operating system UI does not open, only command line.
About os-release follow the image.

Are you using Nvidia GPU driver?

If everything normal, by using sudo systemctl set-default graphical.target and reboot should fix the problem.

But if after reboot you still on tty and not able to go to graphical interface and your system are using Nvidia GPU driver, I believe you should remove Nvidia driver and use nouveau. You could follow the instructions on RpmFusion here Nvidia RpmFusion on part:

  • remove the Nvdia driver
  • recover from Nvidia installer


By following @grumpey suggestions above also worth to try to find any missing packages.

1 Like
sudo dnf distro-sync

Can you please paste the output of this command (as text please, we can’t search through screenshots)? We need to see if it completed correctly and if it threw any warnings.

I think you can’t jump two mayor upgrade. You must upgrade from Fedora 33 to Fedora 34 then you can upgrade to fedora 35.


That is generally true, yes. The suggested way is to upgrade from release X to X+1 because that’s well tested, and the package set does not change too much.

Theoretically, X → X+2 can work, but it depends on the system and what packages are installed. That’s why we need to see the output of the command to see what it says.


Hi guys, thanks for all the suggestions, they were very helpful.

I don’t know what corrupted it when it stopped upgrading the system between 33 to 35, but Fedora identified that the upgrade was complete but apparently it wasn’t, I tried to downgrade to see 34 also without success, I didn’t install the packages.

The solution was to upgrade to 36(Still testing), performed all downloads and installation correctly. Bellow the procedures.

sudo dnf upgrade --refresh
sudo dnf autoremove
sudo dnf --setopt=protected_packages= remove $(dnf repoquery --duplicated --latest-limit=-1 -q)

sudo dnf clean all
sudo dnf system-upgrade download --refresh --reveasever=36

And accepct 36 upgrade.

sudo dnf system-upgrade reboot

After complete the upgrade, I performed the procedure that Syaifur Rizal said,

sudo systemctl set-default graphical.target

And all command from Nvidia RpmFusion to solve the UI Boot.

Now I’m going to test version 36 hehehe…

Thanks so much guys!!! (You saved my life)