WordPress + LAMP on Fedora

Hi. I have installed Apache, MySQL & PHP (LAMP Stack) on Fedora Linux 38 (Workstation Edition), it seems to work. I tried to create a php info file and it works on the browser. Now, I tried to put wordpress and codeigniter in the html folder to install them, setting all permissions at 775, but it gives me access denied error into the browser. How can I fix?

Thanks in advance

Can imagine that you have to give right for the index.php or similar. Alias I can’t see any index in the url?

Or have a look on this.

This is the situation into wordpress folder

Screenshot from 2023-08-24 18-21-00

sudo dnf install httpd mariadb-server wordpress
sudo systemctl enable httpd.service mariadb.service
sudo systemctl restart httpd.service mariadb.service
sudo mysql_secure_installation
sudo mysql << EOI
create database if not exists wordpress;
grant all privileges on wordpress.* to 'wordpress'@'localhost' identified by 'wordpress_passwd';
flush privileges;
sudo sed -i -e "
" /etc/wordpress/wp-config.php

Tested in a Fedora 38 VM, no problem with permissions.

I had to make my /var/www/html folder owned by apache GID and UID, same applied for nginx running on Fedora WS 38 currently. I am serving static content no PHP used.

This would be my next guess … and also pleas do not use userrights 777 this is the wrong approach.

755 should be all right (check doc i linked above).

Basically the same as suggested by @ilikelinux and @jakfrost, but from the source.

The dangers of 777

1 Like

Now works. I’ll try to run codeigniter tomorrow.
Thank you

1 Like