Problems to install new themes in WordPress , installed from f35 repository

I have installed WordPress in my f35 workstation following this tutorial from fedora-magazine web.
That was yesterday, now today after login to the WordPress local installation, URL: localhost/wordpress/wp-admin , there is a problem charging the themes.

[root@fedora chris]# getsebool -a | grep -P "httpd.+--> on"
httpd_builtin_scripting --> on
httpd_can_network_connect_db --> on
httpd_can_sendmail --> on
httpd_enable_cgi --> on
[root@fedora chris]# ^C
[root@fedora chris]# 

I have edited this file: /etc/wordpress/wp-config.php

define('DISALLOW_FILE_MODS', false);

This fixed the problem yesterday and was able to install ASTRA theme and a template.
source: wordpress.stackexchange

But today the problem persists.

can it be permissions issue?


❯ ll -d /etc/wordpress /usr/share/wordpress 
drwxr-x---. 1 root apache  26 Apr 27 16:04 /etc/wordpress
drwxr-xr-x. 1 root root   480 Apr 27 01:10 /usr/share/wordpress

[root@fedora chris]# ll /usr/share/wordpress/wp-content/
total 4
-rw-r--r--. 1 root   root  28 Jan  8  2012 index.php
drwxrwsr-x. 1 apache ftp  264 Apr 27 03:18 plugins
drwxrwsr-x. 1 apache ftp  112 Apr 27 03:11 themes
drwxrwsr-x. 1 apache ftp    0 Apr 27 03:18 upgrade
drwxrwsr-x. 1 apache ftp  612 Apr 27 03:31 uploads
[root@fedora chris]# 

Did you check the last comment on your posted link ?

define(‘DISALLOW_FILE_MODS’, true); - this was my case, but it wasn’t in the wp-config.php, instead, it was in the theme’s functions.php file!

or that one:

Never ran through such problem but I can suggest you to do the following:

If you are a linux user:

$cd path_to_your_wordpress_site/wp-content/
ls -lah
$sudo chmod -R 755 themes

Here h flag to ls command will show you all the ownerships and permissions related to the file. If it didn’t help either

go to the root directory of the web server:

sudo chown -R www-data:www-data your_wordpress_site_folder

above command is for ubuntu

for centos

$sudo chown -R apache:apache your_wordpress_site_folder

I hope it helps.