Wine nvidia-drm

I formatted fedora and installed nvidia drivers and wine(trying to fix a problem, couldn’t fix)
but if use winecfg or play some games(doesn’t happens with every game) this happens

006c:err:winediag:is_broken_driver Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead.
DRM kernel driver 'nvidia-drm' in use. NVK requires nouveau.
DRM kernel driver 'nvidia-drm' in use. NVK requires nouveau.
DRM kernel driver 'nvidia-drm' in use. NVK requires nouveau.
006c:fixme:xrandr:xrandr10_get_current_mode Non-primary adapters are unsupported.
006c:fixme:xrandr:xrandr10_get_current_mode Non-primary adapters are unsupported.
0034:err:winediag:is_broken_driver Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead.
00e8:err:winediag:is_broken_driver Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead.

I don’t know if this makes what I open using nouveau, but it makes the performance run like it is.
I changed nvidia-drm to 0 on /etc/default/grub.conf and regenerated initramfs with dracut but nothing changed

You already have a thread with the same issue, there is no need to create a new thread.
Maybe a moderator will combine them.

Please post the results of inxi -Fzxx here.

From the error it looks like you are trying to run NVK, which does not work with the Nvidia driver.

it didn’t looked exactly like the same thing, sorry.
the retroarch seems to be another problem

wendrew@fedora:~$ inxi -Fzxx
  Kernel: 6.9.5-200.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: GNOME v: 46.2 tk: GTK v: 3.24.42 wm: gnome-shell dm: GDM
    Distro: Fedora Linux 40 (Workstation Edition)
  Type: Desktop Mobo: INTEL model: H61 serial: <superuser required>
    UEFI: American Megatrends v: 4.6.5 date: 07/19/2017
  Info: quad core model: Intel Core i5-3570 bits: 64 type: MCP
    arch: Ivy Bridge rev: 9 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 1596 min/max: 1600/3800 cores: 1: 1596 2: 1596 3: 1596
    4: 1596 bogomips: 27136
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Device-1: NVIDIA GK208B [GeForce GT 710] driver: nvidia v: 470.256.02
    arch: Fermi 2 pcie: speed: 5 GT/s lanes: 8 ports: active: none off: HDMI-A-1
    empty: DVI-D-1,VGA-1 bus-ID: 01:00.0 chip-ID: 10de:128b
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 24.1.0
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 2560x1080 s-dpi: 96
  Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled pos: primary
    model: LG (GoldStar) FULL HD res: 1920x1080 dpi: 102 diag: 551mm (21.7")
  Monitor-2: Unknown-1 mapped: None-1-1 note: disabled size-res: N/A
  API: OpenGL v: 4.6.0 vendor: nvidia v: 470.256.02 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce GT 710/PCIe/SSE2
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
  Device-2: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    speed: 5 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:0e0f
  API: ALSA v: k6.9.5-200.fc40.x86_64 status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 v: kernel
    pcie: speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8136
  IF: enp3s0 state: down mac: <filter>
  Device-2: Ralink MT7601U Wireless Adapter driver: mt7601u type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-1.2:4 chip-ID: 148f:7601
  IF: wlp0s29u1u2 state: up mac: <filter>
  Local Storage: total: 296.21 GiB used: 15.73 GiB (5.3%)
  ID-1: /dev/sda vendor: XrayDisk model: 256GB size: 238.47 GiB
    speed: 3.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: Kingston model: DataTraveler 3.0 size: 57.73 GiB
    type: USB rev: 2.1 spd: 480 Mb/s lanes: 1 serial: <filter>
  ID-1: / size: 56.15 GiB used: 15.37 GiB (27.4%) fs: btrfs dev: /dev/sdb3
  ID-2: /boot size: 973.4 MiB used: 343.3 MiB (35.3%) fs: ext4
    dev: /dev/sdb2
  ID-3: /boot/efi size: 598.8 MiB used: 19 MiB (3.2%) fs: vfat
    dev: /dev/sdb1
  ID-4: /home size: 56.15 GiB used: 15.37 GiB (27.4%) fs: btrfs
    dev: /dev/sdb3
  ID-1: swap-1 type: zram size: 7.72 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 43.0 C mobo: N/A gpu: nvidia temp: 38 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 40%
  Memory: total: 8 GiB available: 7.72 GiB used: 3.16 GiB (41.0%)
  Processes: 926 Power: uptime: 5m wakeups: 0 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 21 Compilers: gcc: 14.1.1 Shell: Bash
    v: 5.2.26 running-in: gnome-terminal inxi: 3.3.34

This is something that I always should put when asking for help? I will remember that

I think I remember one of your older Post here on the forums. Either way, NVK is not supported by your GPU. NVK requires a newer gpu (RTX20XX +) so you can’t use that. I assume this is because of the recent Mesa Update to 24.X, so you will need to downgrade the Mesa to an older version, and reinstall the Nvidia driver.

That might solve your problem. The reason being, Mesa is supporting AMD/Intel and NVK for the first time with 24.X, Most users with your Hardware are locked in to certain versions of tools because their cards cannot run newer versions.

Also, you seem to have issues with WINE & RetroArch. I haven’t used WINE for games in more than 5yrs, because of Proton/GE/tkg, Lutris Scripts, and using the RetroArch Flatpak. So maybe you are running into issues because of a bad configuration.

Just so you know this is not a Fedora related issue. Getting information on whether WINE/RetroArch/NVK is supported with your Hardware is a question for those places.

Here is the documentation on NVK :

Hardware support
NVK currently supports Turing (RTX 20XX and GTX 16XX) and later GPUs. Eventually, we plan to support as far back as Kepler (GeForce 600 and 700 series) GPUs but anything pre-Turing is currently disabled by default.

WINE Forums :

The only thing I did was running the commands for nvidia drivers from rpmfusions. But how do I downgrade this thing?


I only had problems with wine recently, everything was fine. It is related with what you said probably, as even on steam some have problems. I installed the retroarch from the terminal, but it seems that the flatpak version is fine which I am using now. I wanted to play with dolphin on steam version, but after doing everything following a video, the game have problems after launching.

I will do that to fix any issue, thanks

Locked meaning you cannot upgrade certain packages. Because they are incompatible with the hardware. I don’t know what games you are playing, but I would try Lutris, Proton-GE, and Steam Proton Experimental to run your games. it’s much easier to do.

how do I downgrade mesa? I tried sudo dnf downgrade ‘mesa*’
and got Running transaction check Error: transaction check vs depsolve: mesa-filesystem(x86-32) = 24.1.2-2.fc40 is needed by (installed) mesa-va-drivers-24.1.2-2.fc40.i686 mesa-filesystem(x86-32) = 24.1.2-2.fc40 is needed by (installed) mesa-dri-drivers-24.1.2-2.fc40.i686 mesa-filesystem(x86-32) is needed by (installed) libva-2.21.0-3.fc40.i686 To diagnose the problem, try running: 'rpm -Va --nofiles --nodigest'. You probably have corrupted RPMDB, running 'rpm --rebuilddb' might fix the issue. The downloaded packages were saved in cache until the next successful transaction. You can remove cached packages by executing 'dnf clean packages'.

I tried following a video on youtube too and got sudo dnf install /home/wendrew/Downloads/mesa-23.2.1-1.fc40.src.rpm Last metadata expiration check: 0:28:27 ago on Tue 25 Jun 2024 10:00:09 AM -03. Error: Will not install a source rpm package (mesa-23.2.1-1.fc40.src).

I had problems with 3d games too even though I was using proton.

Those three i686 packages are causing the conflict.
I suggest removing them then try the downgrade again.

@computersavvy @hamrheadcorvette
thanks for helping me! I couldn’t exactly fix it but I found a alternative way to do things.

1 Like