Unable to use nvidia drivers after upgrade to fedora 40

the update seems to be applied without error but since impossible to get nvidiaa drivers to work .

luc@fedora:~$ lsmod | grep -iE “nvidia|nouveau”
nouveau 3653632 0
drm_gpuvm 45056 1 nouveau
drm_exec 12288 2 drm_gpuvm,nouveau
gpu_sched 69632 1 nouveau
i2c_algo_bit 20480 1 nouveau
drm_ttm_helper 12288 1 nouveau
ttm 110592 2 drm_ttm_helper,nouveau
drm_display_helper 237568 1 nouveau
video 77824 1 nouveau
mxm_wmi 12288 1 nouveau
wmi 36864 4 video,intel_wmi_thunderbolt,mxm_wmi,nouveau

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

sudo dnf install akmod-nvidia
[sudo] password for luc:
Last metadata expiration check: 0:41:54 ago on Tue 23 Apr 2024 21:27:27 CEST.
Package akmod-nvidia-3:550.76-1.fc40.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
luc@fedora:~$ cat /etc/kernel/cmdline
root=UUID=7a13a122-71a7-4898-a672-d7ff860d513e ro rootflags=subvol=root rd.driver.blacklist=nouveau modprobe.blacklist=nouveau rhgb quiet nvidia-drm.modeset=1 libata.noacpi=1

any help will be greatly appreciated … thanks in advance

booting on the previous kernel make everything works fine if it helps anyone to find out what i should do to get the last kernel working with the nvidia driver

1 Like

Please use the preformatted text tags (the </> button on the tool bar) when posting text copied from the screen so the on-screen formatting is retained and things are more readable.

Please post the output of dnf list installed \*nvidia\* and mokutil --sb-state so we have more information to work with.

You may have also run into the problem shown here and the fix is probably the one in that post


I was having the exact same problem after upgrading to Fedora 40 and the solution you linked to (here) worked for me. Quite easily and quickly I might add!


you’re the best , the <sudo depmod -a> fixed it . Thanks a lot
i found out that mokutil --sb-state check if secure boot is enable on my computer . and it isn’t > Is it something that i must change too ?

1 Like

You do not need to enable secure boot.
Secure boot is a security thing that helps prevent potentially malicious and unsigned software (such as kernels and kernel modules) from loading during boot.

If you are happy with the way things have been running to date it is not necessary to change.

If you decide to enable secure boot it is necessary to follow the instructions on how to locally sign the 3rd party drivers (such as nvidia) and how to enroll that signing key into the bios so secure boot will then allow loading of those modules.
The file /usr/share/doc/akmods/README.secureboot gives instructions for that and will assist in loading any modules that are created using akmods when secure boot is enabled.

1 Like

ok thanks for that clear answer. For now, i’ll stay without the secure boot as it working perfectly fine for me this way . Thanks again