Fedora 40 not working with Nvidia GPU

I saw another post about this topic here, but its proposed solutions did nothing for me.

Here is the run down

  1. My nvidia graphics card does not seem to be working after updating to 40. I have 2 monitors and only one of them is showing now.
  2. The one “working” monitor I have is forced into 4:3 resolution! It’s 1080p 144 hz capable but I’m only allowed to use 1024x768 at 60hz. Of course it should be 1920x1080p. I don’t even have any other option, whereas usually I can lower the resolution.
  3. My graphics card actually almost got fried. You read that correctly. I was frustrated with my debugging for hours on end so I left the computer afk and the screen went blank (to go to sleep). A few minutes later I noticed my entire PC shut off. . . Huh, that’s strange. I tried booting up again. No HDMI signal whatsoever. I eventually disassembled my PC and the graphics card was burning hot to the touch. Which is weird - not like my GPU was actually being used, right?

I turned it off and let it cool down. And then I placed a very nice personal fan next to the GPU. And now I’m once again booted into fedora. So thankfully GPU isn’t toast, for now.

Here’s some details of what commands I’ve run to try setting up nvidia drivers again, from scratch:

$ sudo dnf config-manager --add-repo https://developer.download.nvidia.com/compute/cuda/repos/fedora39/x86_64/cuda-fedora39.repo
$ sudo dnf install kernel-headers kernel-devel tar bzip2 make automake gcc gcc-c++ pciutils elfutils-libelf-devel libglvnd-opengl libglvnd-glx libglvnd-devel acpid pkgconfig dkms
$ sudo dnf module install nvidia-driver:latest-dkms

Anyway, let me know what further technical details I should provide.

I don’t think you have your drivers installed properly.

Also, that thread you linked is completely unrelated to the issues you are having.

The forums recommends you install the driver using the RPMFusion way, and if you have secureboot & cuda there are instructions for that as well.

Your details shows the link from nvidia’s site and the use of DKMS :

  • The Nvidia driver is best installed from one of the repos, the Nvidia driver breaks a lot.
  • I you need DKMS, CUDA and other HWACCEL tools there are other reliable repos as well. (I use one for my specific usecase )

I tried running this command denoted here

$ sudo dnf install akmod-nvidia

Which resulted in the following error message:

 Problem: conflicting requests
  - package akmod-nvidia-3:550.67-1.fc40.x86_64 from rpmfusion-nonfree requires nvidia-kmod-common >= 3:550.67, but none of the providers can be installed
  - package akmod-nvidia-3:550.76-1.fc40.x86_64 from rpmfusion-nonfree-nvidia-driver requires nvidia-kmod-common >= 3:550.76, but none of the providers can be installed
  - package akmod-nvidia-3:550.76-1.fc40.x86_64 from rpmfusion-nonfree-updates requires nvidia-kmod-common >= 3:550.76, but none of the providers can be installed
  - package xorg-x11-drv-nvidia-3:550.67-1.fc40.x86_64 from rpmfusion-nonfree is filtered out by modular filtering
  - package xorg-x11-drv-nvidia-3:550.76-1.fc40.x86_64 from rpmfusion-nonfree-nvidia-driver is filtered out by modular filtering
  - package xorg-x11-drv-nvidia-3:550.76-1.fc40.x86_64 from rpmfusion-nonfree-updates is filtered out by modular filtering

And when I tried adding the --skip-broken switch, it resulted in:

Dependencies resolved.

 Problem: package akmod-nvidia-3:550.76-1.fc40.x86_64 from rpmfusion-nonfree-nvidia-driver requires nvidia-kmod-common >= 3:550.76, but none of the providers can be installed
  - cannot install the best candidate for the job
  - package xorg-x11-drv-nvidia-3:550.76-1.fc40.x86_64 from rpmfusion-nonfree-nvidia-driver is filtered out by modular filtering
  - package xorg-x11-drv-nvidia-3:550.76-1.fc40.x86_64 from rpmfusion-nonfree-updates is filtered out by modular filtering
===============================================================================================================================
 Package                   Architecture        Version                      Repository                                    Size
===============================================================================================================================
Skipping packages with broken dependencies:
 akmod-nvidia              x86_64              3:550.76-1.fc40              rpmfusion-nonfree-nvidia-driver               40 k

Transaction Summary
===============================================================================================================================
Skip  1 Package

Nothing to do.
Complete!

I would recommend :

https://rpmfusion.org/Howto/NVIDIA

CUDA :

https://rpmfusion.org/Howto/NVIDIA#CUDA

I would uninstall the stuff you tried and try again with these methods.

1 Like

I started this process right now by uninstalling all nvidia stuff.

$ dnf list installed '*nvidia*' | tail -n 15 | awk '{print $1}' | xargs sudo dnf remove -y

Such that when I tried searching for installed instances, nothing showed up. Fresh slate.

I started by trying this , as my GPU is after 2014 (what it considers “non legacy”).
This section lists commands I have already tried running. This one in particular breaks as I described in my last response.

sudo dnf install akmod-nvidia

As far as CUDA installation attempt, I received this error

$ sudo dnf install xorg-x11-drv-nvidia-cuda
Error: Unable to find a match: xorg-x11-drv-nvidia-cuda

When I try searching for cuda:

$ dnf search 'nvidia' | grep 'cuda'

nvidia-driver-cuda.x86_64 : CUDA integration for nvidia-driver
nvidia-driver-cuda-libs.i686 : Libraries for nvidia-driver-cuda
nvidia-driver-cuda-libs.x86_64 : Libraries for nvidia-driver-cuda
xorg-x11-drv-nvidia-390xx-cuda-libs.i686 : CUDA libraries for xorg-x11-drv-nvidia-390xx
xorg-x11-drv-nvidia-390xx-cuda-libs.x86_64 : CUDA libraries for xorg-x11-drv-nvidia-390xx
xorg-x11-drv-nvidia-470xx-cuda-libs.i686 : CUDA libraries for xorg-x11-drv-nvidia-470xx
xorg-x11-drv-nvidia-470xx-cuda-libs.x86_64 : CUDA libraries for xorg-x11-drv-nvidia-470xx
xorg-x11-drv-nvidia-cuda-libs.i686 : CUDA libraries for xorg-x11-drv-nvidia
xorg-x11-drv-nvidia-cuda-libs.x86_64 : CUDA libraries for xorg-x11-drv-nvidia
cuda-nsight-compute-12-4.x86_64 : NVIDIA Nsight Compute
cuda-nsight-systems-12-4.x86_64 : NVIDIA Nsight Systems
cuda-nvtx-12-4.x86_64 : CUDA NVIDIA Tools Extension
libnvimgcodec-cuda-11.x86_64 : NVIDIA nvImageCodec library for CUDA 0.
libnvimgcodec-cuda-12.x86_64 : NVIDIA nvImageCodec library for CUDA 0.

My GPU isn’t part of either of the explicit series listed, so I just installed nvidia-driver-cuda.x86_64. That installation actually ran, so I’m going to try rebooting and seeing what happens.

1 Like

After installing just the nvidia-driver-cuda.x86_64 package, I am still unable to see my 2nd monitor in Gnome’s display settings and the first monitor remains locked in 4:3.

I have successfully installed Nvidia again on Fedora40, so I will document it here and mark solved.

Note: I’m still not sure what caused my GPU to overheat and shutdown after installing (while the system was idling/sleeping). So I am still somewhat concerned with that.

Working nvidia-driver re-installation process:

$ sudo dnf module disable nvidia-driver
$ # uninstall all nvidia related packages again
$ sudo dnf install akmod-nvidia
$ sudo dnf install xorg-x11-drv-nvidia-cuda

For some reason I am not educated on, I had to disable the non-functioning nvidia-driver module.

Here is a link to another post that helped me.

Here is the direct rpmfusion support link for Nvidia that was also part of the solution.

And thanks @hamrheadcorvette for assisting me

3 Likes

That is an artifact from installing nvidia from a repo other than rpmfusion and conflicts when installed from rpmfusion. Your actions were correct.

You should check the enabled repos with dnf repolist and if it shows any nvidia or cuda repos enabled they should be disabled to avoid this type conflict in the future.

I would venture that the GPU over heating may have been driver conflicts with conflicting files installed from different repos.

3 Likes

Thanks for your input. I think I agree - my best guess is the fans on the GPU were not operational since the update. Still I was not rendering any games or videos, but I suppose it was still enough to not passively dissipate. It’s speculation at this point.

dnf repolist indeed has 2 of them

cuda-fedora39-x86_64            cuda-fedora39-x86_64
rpmfusion-nonfree-nvidia-driver RPM Fusion for Fedora 40 - Nonfree - NVIDIA Driver

This would be the conflicting repo and should probably be disabled with
sudo dnf config-manager --disable cuda-fedora39-x86_64

16 posts were split to a new topic: Nvidia driver not loading

just upgraded to Fedora 40 - had the problem with nvidia gpu… this post saved me in couple of minutes. Cheers!

hi. wanted to share me experience with the team on how I got Nvidia to work with my desktop (about 12 years old) with FC39.

here’s the VGA details of my machine

        *-pci:0
             description: PCI bridge
             product: RD890/RD9x0/RX980 PCI to PCI bridge (PCI Express GFX port 0)
             vendor: Advanced Micro Devices, Inc. [AMD/ATI]
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 00
             width: 32 bits
             clock: 33MHz
             capabilities: pci pm pciexpress msi ht normal_decode bus_master cap_list
             configuration: driver=pcieport
             resources: irq:24 ioport:e000(size=4096) memory:fb000000-fcffffff ioport:c0000000(size=536870912)
           *-display UNCLAIMED
                description: VGA compatible controller
                product: GT218 [GeForce 210]
                vendor: NVIDIA Corporation
                physical id: 0
                bus info: pci@0000:01:00.0
                version: a2
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress vga_controller bus_master cap_list
                configuration: latency=0
                resources: memory:fb000000-fbffffff memory:c0000000-cfffffff memory:de000000-dfffffff ioport:ef00(size=128) memory:c0000-dffff

I upgraded from FC37 to FC39 and the display changed to a black screen and a blinking cursor on the top left corner.

went through a lot of troubleshooting issues and here’s what i did to fix it

1 - Get machine to rescue mode
https://www.youtube.com/watch?v=e-NauoY3m50

2 - came to this post and did the following steps

$ dnf update
$ dnf module disable nvidia-driver
$ dnf list installed '*nvidia*'
$ dnf remove '*nvidia*'
$ shutdown -r now

The machine booted and showed me the login screen. finally after almost 3 days of troubleshooting got it running.

also checked to see if i have any nvidia packages in there, and it showed none

$ rpm -qa | grep -i nvidia
$ rpm -qa | grep -i kernel
kernel-modules-core-6.8.6-100.fc38.x86_64
kernel-core-6.8.6-100.fc38.x86_64
kernel-modules-6.8.6-100.fc38.x86_64
kernel-devel-6.8.6-100.fc38.x86_64
kernel-6.8.6-100.fc38.x86_64
kernel-modules-extra-6.8.6-100.fc38.x86_64
kernel-headers-6.8.3-200.fc39.x86_64
kernel-srpm-macros-1.0-20.fc39.noarch
kernel-modules-core-6.8.6-200.fc39.x86_64
kernel-core-6.8.6-200.fc39.x86_64
kernel-modules-6.8.6-200.fc39.x86_64
libreport-plugin-kerneloops-2.17.11-3.fc39.x86_64
kernel-devel-6.8.6-200.fc39.x86_64
abrt-addon-kerneloops-2.17.1-3.fc39.x86_64
kernel-6.8.6-200.fc39.x86_64
kernel-modules-extra-6.8.6-200.fc39.x86_64
kernel-modules-core-6.8.7-200.fc39.x86_64
kernel-core-6.8.7-200.fc39.x86_64
kernel-modules-6.8.7-200.fc39.x86_64
kernel-devel-6.8.7-200.fc39.x86_64
kernel-6.8.7-200.fc39.x86_64
kernel-modules-extra-6.8.7-200.fc39.x86_64

thanks forum members for the insightful tips.
yashesh

Glad you got your system working. As you discovered, support for the closed source Nvidia drivers is problematic. You may be using the open source nouveau driver, which I find works well for me (mostly using command-line tools, email, and this forum in firefox) with Wayland, but I do sometimes need the Nvidia hardware. If your system has non-Nvidia graphics you may not be using your Nvidia hardware.

RPMFusion Nvidia How will tell you how to install Nvidia drivers in Fedora, with details of configuration for different hardware, including switching between nouveau and Nvidia drivers.

Hello George. Thanks for the pointer. So now if I want to install Nvidia drivers using the RPMFusion NVidia How. Which one would work for me pls.

my card is

description: VGA compatible controller
product: GT218 [GeForce 210]
vendor: NVIDIA Corporation

I have to use this one pls ? 1. Legacy GeForce 8/9/200/300

thank you.

yashesh

Yes: Legacy GeForce 8/F9/F200 F300

Please start a new thread specific to this model, as you can see at that link:

EOL by NVIDIA at the end of 2019. Still available on “best effort basis” (newer kernel may break, will be discontinued at anytime if not actively maintained)

By creating a thread with a title that includes “Legacy GeForce 8/F9/F200 F300” you may get advice from others with similar hardware.

You should start planning for a replacement.

1 Like

This command does remove one normally required nvidia package.
The package nvidia-gpu-firmware is installed from fedora and should be reinstalled with
dnf install nvidia-gpu-firmware

The firmware package may be required by the GPU regardless of the driver in use.

done. thanks.

That command saved the day after several hours trying to install nvidia

$  sudo dnf module disable nvidia-driver

Thanks,
And I have similar issue on my laptop after wake from sleep when GPU fan won’t go on so it overheats and laptop freezes (Gigabyte G6 with RTX4060), so I found a way to always (when I don’t forget) start GMiner for 30s-1min after wakeup, to get GPU fans going and than it’s OK, though fans run all the time with same speed, but at least no overheating.