Windows Dual-Boot installation issue

So I want to dual boot with Fedora and I’ve just partitioned my SSD with 256gb of “unallocated” space to install fedora using a USB, but when I boot it up and get the installer going my hard drive doesn’t show up in any way as a possible destination to install fedora? I’m not sure whats going on or what to do.

Someone suggested I format the unallocated space to ntfs, so I tried that without any luck.

Any help would be much appreciated!

Start fedora live.
Then do “ls /dev” to see what devices are seen and configured and give us the results.

You don’t say what the hardware is, but the drives should be configured as /dev/sdX with /dev/sdX1, /dev/sdX2, etc. or /dev/nvmeX with /dev/nvmeXp1, /dev/nvmeXp2, /dev/nvmeXp3, etc. as the existing partitions. If you have a newer laptop then for your SSD it will likely be the nvme above.

If you are installing as dual boot you do NOT want to use automatic storage configuration because that will wipe out the windows install.

BTW, you will want to remove the new partition that you formatted as ntfs because you need “unallocated” empty space for the install.

If you have never done a dual boot install this thread goes through the steps pretty thoroughly.

This is the laptop I’m using

Copy that on the automatic storage configuration, it was pre-selected, but once I’m able to make a selection what’s the appropriate one?

I’ve just followed your instructions and this is what I got

I didn’t see anything close to what you mentioned

And I’ve removed the partition

Check your BIOS for software RAID. Your SDD may have been set up with RAID (common with recent HP products I have come in contact with). If so, disable the RAID and switch to AHCI. Usually, there is a way to do it without loosing data (preserve Windows)


Once the drive can be seen, the drive to be selected is “sda”, seen in /dev as sda, sda1, sda2 and sda3. sda is the drive, sda[1, 2, and 3] are the 3 existing partitions on the drive

The detailed instructions from the link in my earlier post should guide you for the rest of the install, as will most of the many posts here about dual boot installs.

Please follow the part about using the windows efi partition and mounting it at /boot/efi without formatting. The efi partition should be sda1, but verify before you use it. It should show as (efi system partition) to the installer.
Everything else can be put into the free space you provided.

Okay I can confirm that RAID is enabled, what is it? and do you know how to switch to AHCI without loosing data?

Thank you!

What’s your machine spec? Can you share a screenshot of the relevant BIOS page? Usually, there is a toggle for such things but they vary between machines.

1 Like

Got it done! Everything was going smooth, I was following this tutorial when I encountered a problem around step 10. The installer says “Error checking storage configuration”, and doesn’t let me proceed.

So this is my new sticking point.

image of the actual error I’m getting

I tried this option per computersavvy’s thread, but it didn’t make any difference

finally these are some more details I was able to find after setting the partition to efi

Apologies for the different replies, the forum wont let me add multiple photos in a single post

Oh my … !

@imntesta is in a hurry to get Fedora into his machine! That’s good … that’s very good except that hurrying often introduces more problems. Some of those screenshots are quite scary, my friend. Don’t do those.

You need to take the following steps:

  1. You already have three (3) partitions on the SSD (nvme0n1p1, nvme0n1p2, and nvme0n1p3)
  2. Since Windows is already on the Machine, I assume it is nvme0n1p3 (678.32GiB). That means nvme0n1p1 should be an EFI System Partition (ESP). Please note this specifically … You do not need another EFI partition. You already have one. Also … what ever you do, DO NOT … don’t format the existing EFI partition because that will elongate your journey and surely make you despondent. Don’t do it. You are warned!
  3. Create the following partitions on the free space 256GiB (/boot, /, /home, and /swap)
  4. Set the mount-point for nvme0n1p1 to /boot/efi (assuming nvme0n1p1 is actually the ESP … I am betting on it). See? You are only mounting the existing EFI partition, you do not need to create one – no need to format that too.
  5. Now run the installation

How did it go?

Haha I sure am!

When creating those partitions on the free space 256gb, is that something I do within windows disk manager or within the Fedora installer? How exactly do I go about that and how much space should I allocate to each?

Sorry for all the questions, just want to make sure I get this right.

Thank you!

You do that within Fedora Installer please.

The sizes are up to you … but I suggest you reserve about 40GiB to 50GiB for / (root partition). /boot can be 1GiB (512MB might just do since only kernels are stored there but I like overheads so mine is 1GiB. /swap can be 8GiB (I have seen recommendations in favour of twice the size of your RAM. However, this also depends on your computing needs. Fedora may not use the physical swap space if you have enough RAM for your computing needs).

You can allocate the remaining space to /home. Eventually, your data will live in /home. So, it deserves enough space to take whatever you will be throwing in there

1 Like

imntesta has me confused as to exactly what he is doing and why he is using 2 different machines. He has posted different machine photos here so I cannot be certain we are even giving him correct guidance.


Here he showed he was working on a machine with a standard HDD shown as /dev/sda

now during the install he shows he is working on a machine with an nvme SDD

Those show two distinctly different machines and he is having problems following guidance already given. I am confused!!! :thinking:

It is possible that @imntesta is running the installation from a USB live media. However, I am not sure how ls /dev will represent the live USB. I can confirm that USB sticks are labelled like regular HDDs. My 4GB stick bears /dev/sdc1 as at the time of writing

When running from live USB I see the partitions on the USB as /dev/sdaX, etc. but that would not explain why /dev/nvme0 did not show on his first pic above. It seems that he has to be posting pics from 2 different machines.

See this response.
Some computers ship with hard-drives configured with software RAID (BIOS). Such drives are not detected by Anaconda. In @imntesta’s case, the SDD showed up after he changed the configuration from RAID to AHCI

1 Like

Ahhhh! :grimacing:
I don’t use Dell, thus am not used to that dell bios so I missed that. Still confused but better. :thinking:

Thank you both for your help! I just got home from work and I’ll be giving your suggestions a shot.