Error checking storage configuration - Fedora 39

Hello all,

I have been using Fedora for a long time, unfortunately i had to go back to windows for couple years, now i want to come back to using fedora/windows as dual boot in a new laptop.

I have :

  • Asus TUF 17 gaming
  • Windows 11 ( preinstalled)
  • Bitlocker disabled
  • secure boot disabled
  • fast boot disabled

I tried to install Fedora 39 and allocated 900 Go to it ( free partition) and when i choose the drive where that free space is ( it recognized that there is 900 go free space) i get this message : “Error checking storage configuration” which never happened before i got this laptop.

Could someone please help ? i have spent 4 hours fighting with it and trying things but nothing helped

Thank you .

Add images

There are logs you can look at in other consoles. Its been a while since I did
this so I have forgotten the details.

Try Ctrl-Atl-F1 … Ctrl-Alt-F9 until you find a consoles with log lines of a shell prompt.
You should be able to find logs lines that provide insight in to why you got that error.

When you freed the space on nvme0n1 did you by chance create a new partition or did you leave it unallocated? If the partition was created then fedora does not have free space in which to install.

Make certain there are no partitions existing in the space where you intend to install fedora.

I actually tried both, i formated with EXT4 it didn’t work and I tried to delete the partition using partition tool it didn’t work either and i also tried to free and claim that space by deleting that partition using Advanced custom in Fedora installer, didn’t work…i always get the same error message

Sorry the app is in French, non alloué means : not allocated

It’s been years i didn’t work on linux, i have no idea how to do that…

From that image it actually appears there is a partition there, though I am not sure since I do not read french. It looks like a partition that has not yet been formatted.

Please run the windows disk manager and verify that the drive shows the indicated space as unallocated. If it does not then remove whatever partition is there before trying the install again.

You could do the same when booted to the live fedora image being used for the install and use the command sudo fdisk /dev/nvme0n1 and view/manipulate the partitions.

Fedora must have unallocated free space on the drive before starting the install if you intend to use the automatic partitioning to perform the install.

I tried to install only fedora, i wiped out windows and all partitions and did a fresh installation of Fedora and it worked fine, i wiped out my drive again and installed windows on it and tried the same, i made sure the space for Fedora is unallocated and tried again, got the same issue.

I give up, i think i will continue with windows, thank you all for your time and answers :slight_smile: