Windows 10 partition not recognized as bootable

TL;DR for people that could be going through the same problem. I’m trying to boot into the Windows partition, that partition is being recognized by Disks Utility, but not by the BIOS or the GRUB menu. Therefore, I can only boot into Fedora. Fedora and Windows are both already installed on separated disks.

I installed Windows 10 on a 300GB partition of a 1TB HD (Left 700GB for personal use) and later installed Fedora 36 on a 500GB SSD. The output of lsblk is the following:

sda      8:0    0 931.5G  0 disk 
├─sda1   8:1    0 279.4G  0 part /mnt/sda1
└─sda2   8:2    0 652.1G  0 part /mnt/sda2
sdb      8:16   0 465.8G  0 disk 
├─sdb1   8:17   0     1G  0 part /boot
└─sdb2   8:18   0 464.8G  0 part /home
zram0  252:0    0     8G  0 disk [SWAP]

where sda1 is the partition with Windows 10, sda2 is the personal use partition, sdb1 and sdb2 are the SSD partitions with Fedora. However, when I turn on the computer and get into the BIOS boot options, there’s only one option with the Fedora boot and none for the HD’s partition with Windows. The GRUB menu only shows Fedora too. I want to boot into Windows and then include it in the GRUB menu options without reinstalling Windows.

Edit: GNOME Disks recognizes all the partitions and I can access the Windows Files through the Files Explorer (nautilus). However the boot doesn’t recognize any of the HD partitions (sda1 or sda2) for some reason. sda1 partition is called Windows Fig and as you can see I can access its files:

Welcome to ask.:fedora:edora @figaro

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

For me it looks like that you are booting in legacy mode. For this the Windows partition needs to be active and have a boot flag. But first we need more info’s about your system to give you more specific instructions.

1 Like
  Kernel: 5.18.5-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.2
    Distro: Fedora release 36 (Thirty Six)
  Type: Laptop System: ASUSTeK product: VivoBook 15_ASUS Laptop X542UF v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X542UF v: 1.0 serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: X542UF.304 date: 08/03/2018
  ID-1: BAT0 charge: 27.1 Wh (99.6%) condition: 27.2/38.0 Wh (71.6%)
    volts: 7.7 min: 7.7 model: ASUSTeK ASUS Battery status: not charging
  Info: quad core model: Intel Core i5-8250U bits: 64 type: MT MCP
    arch: Coffee Lake rev: A cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 1201 high: 2077 min/max: 400/3400 cores: 1: 800 2: 1914
    3: 2077 4: 1453 5: 966 6: 800 7: 800 8: 800 bogomips: 28800
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel
    bus-ID: 00:02.0
  Device-2: NVIDIA GM108M [GeForce MX130] vendor: ASUSTeK driver: nouveau
    v: kernel arch: Maxwell bus-ID: 01:00.0
  Device-3: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-6:4
  Display: wayland server: X.Org v: with: Xwayland v: 22.1.2
    compositor: gnome-shell driver: gpu: i915 resolution: 1: 1360x768~60Hz
    2: 1360x768~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2)
    v: 4.6 Mesa 22.1.1 direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Device-2: Texas Instruments PCM2902 Audio Codec type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1:2
  Sound Server-1: ALSA v: k5.18.5-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus-ID: 02:00.0
  IF: enp2s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: AzureWave driver: ath10k_pci v: kernel bus-ID: 03:00.0
  IF: wlp3s0 state: up mac: <filter>
  Device-1: IMC Networks type: USB driver: btusb v: 0.8 bus-ID: 1-8:5
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 1.36 TiB used: 104.93 GiB (7.5%)
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
  ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO M.2 500GB
    size: 465.76 GiB
  ID-1: / size: 464.76 GiB used: 4.23 GiB (0.9%) fs: btrfs dev: /dev/sdb2
  ID-2: /boot size: 973.4 MiB used: 227.9 MiB (23.4%) fs: ext4
    dev: /dev/sdb1
  ID-3: /home size: 464.76 GiB used: 4.23 GiB (0.9%) fs: btrfs
    dev: /dev/sdb2
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 41.0 C pch: 31.5 C mobo: N/A
  Fan Speeds (RPM): cpu: 2600
  Processes: 760 Uptime: 8h 20m Memory: 15.5 GiB used: 3.24 GiB (20.9%)
  Init: systemd runlevel: 5 Compilers: gcc: 12.1.1 Packages: N/A
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.16

If you unhook SATA cable on SSD … what happens? Windows NT and Linux have different tools for this and that, if Windows is the culprit simply use Microsoft tool kit.
You can use NTFS file system on Linux, you can also use BTRFS file system in Windows being the default file system in Fedora and used in ReactOS => Open source Winbtrfs with link in GitHub.

1 Like

Both Disks are inside the laptop. But that’s a good question, that based on my experience of trial and error booting, my guess is that the computer will stop working because there could be something wrong with the Windows partition’s boot protocol.

You reinstall W10 from Microsoft website. After you need a Microsoft account to valid the license on installation. It’s the same thing as Fedora with account like Google.

1 Like

How does having an account solves the problem? Also, I think I’ll be reinstalling because I’ve been having trouble with this for 2 days without a solution. However, I consider that this problem might be so trivial that can be solved without reinstalling everything (because I already configured Windows 10 for like 4 hours removing the bloat and spyware).

Hello @figaro ,
welcome to :fedora: ,
You say that you can’t even get Win10 to boot from BIOS (I assume UEFI?)? If this is the case, you likely have somehow borked the esp, and may have to “grin and bear it” and just re-install (grub will need redoing after). In dual booting scenarios, I have chosen to increase the size of the /boot/efi partition to around 600mb since I ran into issues with the recommended size from the doc’s.
Does Fedora Linux boot from the BIOS boot menu?


Yes, I’m using Fedora right now to write this post and I previously could boot into Windows before installing Fedora.

maybe try grub2-probe <windows-device>? If you do any changes to grub I think grubby is the recommended tool to add/modify menu items, and grub2-mkconfig needs to be run afterwards to write the changes.

1 Like

I have reinstalled Windows and Fedora, and now both work flawlessly. However I’m a bit bothered by the fact I wasted so much time (backups and customizing again) in something that maybe could be solved by using the terminal. Nonetheless I thank you for assisting correctly in my problem. I marked the reinstalling comment as a solution.

P.S. I tried the grub2-probe solution without success after reinstalling Windows 10 (before reinstalling Fedora again) and had no success even when the BIOS recognized Windows 10 as a bootable partition again. I tried all the solutions above with the same result, therefore, I reinstalled Fedora too.