Wifi not working after using proton vpn

The titles really says it all. I used proton VPN and when I disconnected my wifi stopped working. (It works on other devices)

What I have tried:
Deleting all vpn in network settings (worked for a bit but my stupid self ran proton again and now there is nothing there + wifi dosent work)
Changing dns address to and
systemctl restart NetworkManager.service

Thank you in advance!

Type “nmcli con” and delete pvpn-ipv6leak-protection and, if there, pvpn-routed-killswitch using “nmcli con delete”.
This is not a Fedora problem, but a Proton problem leaving persistent connections in NetworkManager if the app is not closed properly. If you have a paid account, please report.


Thank you! This worked. Sadly I do not have a premium proton account, but at least now people who are lost like i was can stumble on this thread hopefully.


thank you as well. I already was thinking about reinstalling fedora thanks again. Created an account to thank you)

This is unfortunately “world wide” known bug. It bugs me almost every time when I reboot my laptop before I disconnect it from vpn.

When using a vpn it should become habit to disconnect the vpn before shutting down or rebooting for the exact reason noted.

It works just fine when VPN is properly configured with NetworkManager, so the problem should be caused by third-party apps.

I know, but sometime I forgot .

If you mean using the in NetworkManager imported proton OVPN file, there is no problem at all, but there is one other thing to consider: if you have a working IPv6 configuration, your IPV4 will go via VPN and your IPv6 goes via the normal connection.
This might not be what you want when using VPN.

By the way, because Proton’s ovpn files contain IP addresses of the VPN servers, the most simple solution to fix the problem might be : startup the VPN via app.

If your VPN doesn’t support IPv6, then you can just disable IPv6 on your main connection.