ProtonVPN don't work

OS = Fedora Linux 37 x86_64
Kernel = 6.1.10-200.fc37.x86_64

$ protonvpn-cli connect --fastest --protocol udp

Connecting to Proton VPN on NL-FREE#364156 with UDP.

Unable to connect to Proton VPN: 
Proton VPN connection failed due to unknown reason.

notificatond says:

it was not possible to establish a connection 
because the correct registration data was not provided in the VPN

When I try import saved VPN configuration to NetworkManager I get blank VPN tab


sudo openvpn --config

works perfectly

Any thoughts?

the same ProtonVPN at Fedora Linux 37 x86_64 CINNAMON
works with minor remarks.

Reconfigure it, looks like you lost the registration data.

Are you using the free Account? If yes log in at proton and see what is wrong.

Normally reconfigure it helps.

check for updates and verify if there is no error.

What should I reset?
login/password ?

Nothing wrong with account.

Besides, I said
1- at another PC proton works
2- openvpn works also

works with the same credentials.

updates also OK

No. The VPN config you made on the computer. And or reinstall protonvpn-cli.
I had once such a problem after changing the python version. Fedora was new and proton was still with the old one.

protonvpn-cli I reinstalled 100 times.

I don’t know how to make VPN config on the computer.

May you show step-by-step?


Just try then protonvpn-cli connect select a other server or country and see if you get same error.

My kernel and proton-cli versions are:

Proton VPN CLI v3.13.0 (protonvpn-nm-lib v3.14.0; proton-client v0.7.1)

Sorry I can not reproduce your error.

I use gnome.

No problem with connecting nor import of OVPN file.
On my system, protonvpn-cli --get-logs works correctly with the nl_NL.UTF-8 .locale.
Could it be some localization problem? I do not see anything special in the OVPN but there should be some reason why you cannot import it.
NetworkManagger stores certificates in ~/.cert/nm-openvpn
Is this folder accessible? Does it work from a freshly created user account?

Any country, any server - the same error.

$ locale

at another PC with the same locale all work

~/.cert/nm-openvpn available

$ cd .cert
[archer@DELLV .cert]$

[archer@DELLV .cert]$ ls -l nm-openvpn
загалом 272
-rw-------. 1 archer archer 2017 лют 11 18:07
-rw-------. 1 archer archer 632 лют 11 18:07
-rw-------. 1 archer archer 2017 лют 13 15:12
-rw-------. 1 archer archer 632 лют 13 15:12
-rw-------. 1 archer archer 2017 лют 9 15:34 ProtonVPN-zpbm_9pv-ca.pem
-rw-------. 1 archer archer 632 лют 9 15:34 ProtonVPN-zpbm_9pv-tls-auth.pem
[archer@DELLV .cert]$

With another user the same error.

thank you all

I’m thinking of contacting ProtonVPN support.

Do you have NetworkManager-openvpn-gnome installed? This at least could explain the blank openvpn import.
Proton from NetworkManager works perfect after import, but be sure to disable IPv6, if enabled, there is no ipv6 leak protection which is activated in protonvpn-cli or app.

Proton should add this package as dependency, protonvpn-cli fails too is this is missing.

Additional comment: “nmcli con up protonovpnconnection” does run without asking for the openvpn credentials if networkmanager-openvpn-gnome is installed, but requires the “–ask” option and password entry if it is not installed. Since Proton interacts with NetworkManager, one could argue whether this is a Proton, Fedora or upstream NetworkManager problem. The complexity of package dependencies almost forces third parties to distribute software as flatpak or container…

@hmmsjan NetworkManager-openvpn-gnome I have this because I use gnome.

Does this work also with lxqt ? Is this gnome based DE? As @sparcher uses it.

It is awesome

At my first post I said:
my DE is LXQt

Naturally no gnome packs.

After install NetworkManager-openvpn-gnome +dependencies libnma-gtk4

all begins work

P.S. At my another PC DE=CINNAMON
NetworkManager-openvpn-gnome was from the very beginning

that’s why everything worked there


thanks again everyone for your help

Problem solved.

nm-connection-editor works on lxqt, so I assume NetworkManager-openvpn-gnome works too, if all necessary libraries are loaded as dependency.
In this case, it looks like NetworkManager-openvpn and NetworkManager-openvpn-gnome are such related that the functionality of a command-line program changes.
Question for the packagers: should openvpn-gnome added as dependency, forcing installation of a lot of gnome software on a server system…

I am not sure the full package NetworkManager-openvpn-gnome should be required, but certainly Network-Manager-openvpn should pull in all the needed dependencies to function.

I would suggest that you file a bug report against NetworkManger-openvpn and show what you had to do to enable it to work.

1 Like

Would it not make more sense, to add on
A note, that for small footage fedora versions, a gnome pendency would be needed and has to be installed separately, making protonvpn-cli working?
As we talked about the protonvpn-cli here.

Sorry, it is not so easy to file bug reports there.
The problem is “/usr/libexec/nm-openvpn-auth-dialog”, if this file is present, the software works. The program source is in the “networkmanager-openvpn” git.
Fedora has only one source RPM including both "networkmanager-openvpn’ and “networkmanager-openvpn-gnome” The SPEC file directs nm-openvpn-auth-dialog to the “networkmanager-openvpn-gnome” rpm. So this seems not 100% correct, but including this file in the other rpm might introduce unnecessary dependencies in many cases. Simplest solution would be to make it dependency in the proton package, there it’s needed. According to, most or all rpm-based distributions pack the program in the nm-openvpn-gnome.