[How-to] Proton VPN: killswitch stuck on + a solution

Hi all, just updated to F35 from F34 and had some connectivity issues while using the ProtonVPN killswitch. I tried searching for a solution, but ended up discovering one with some investigation.

I had the permanent killswitch enabled, updated to the new Fedora 35 and it removed my Proton packages but somehow left the killswitch active on my machine, which took some time to figure out. I thought I’d document it here for anyone who may be looking for a solution to the same problem.

Looking at the network manager, you can see full connectivity/connected state, but a ping yields no result.

root@jfed joel]# nmcli g
connected  full          enabled  enabled  enabled  enabled 

[root@jfed joel]# ping
PING ( 56(84) bytes of data.
--- ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3106ms

Below, I ran nmcli c to see what may be active and to my surprise, the ProtonVPN killswitch was still there, blocking my connection, even when I didn’t have protonvpn-cli or the GUI packages installed, which meant I could not intuitively turn it off.

[root@jfed joel]# nmcli c
NAME                UUID                                  TYPE      DEVICE       
pvpn-killswitch     [redacted]                            dummy     pvpnksintrf0 

The solution - mark the protocol as down, like below:

[root@jfed joel]# nmcli c down pvpn-killswitch 
Connection 'pvpn-killswitch' successfully deactivated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/1)
[root@jfed joel]# ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=118 time=18.5 ms
64 bytes from icmp_seq=2 ttl=118 time=24.8 ms
64 bytes from icmp_seq=3 ttl=118 time=19.8 ms
64 bytes from icmp_seq=4 ttl=118 time=18.0 ms
--- ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3005ms
rtt min/avg/max/mdev = 18.042/20.294/24.807/2.682 ms

As you can now see, ping yields results and now I can reinstall the ProtonVPN client and use the killswitch as it’s intended.

Hope this helps someone else!

Thanks for sharing!

I think probably actually the best way to do this kind of thing here is to put it in the form of a question, and then answer the question yourself in a reply. (You could temporarily put “Note: providing an answer myself in a bit — hold in!” at the bottom of the question and then edit that out when done.)

That way, it can be in the regular help category instead of of community discussions. (If you want to edit the post + a reply into that form, I can move the category. Or actually I think you can do that yourself?)

1 Like