Why redshift doesn't start with system?


I’m trying to run redshift automatically after system startup. I have already tried:

Crontab, I pasted this command: @reboot export DISPLAY=:0.0 && /usr/bin/redshift -l 50.09:19.92 -t 6500:3400 -o

Upstart, I edited /etc/rc.local:


sudo /usr/bin/redshift -l 50.09:19.92 -t 6500:3400 -o

exit 0

Xprofile, I made ~/.xprofile file:

/usr/bin/redshift -l 50.09:19.92 -t 6500:3400 -o &

But it still doesn’t work :frowning: Do you have any idea what else I could try?

OS: Fedora 35 with KDE

Redshift version: 1.12

1 Like

Hi, as far as I know, redshift only work on x11 session. Please try to login to x11/xorg session and not wayland session. Then check with echo $XDG_SESSION_TYPE.

1 Like

Hey Karol, if you only want Redshift to run automatically at startup, a cronjob isn’t really necessary. Though I’m not currently using KDE, I’m sure it has a app that manages ‘startup’ applications which you can search up in application menu.

You can add Redshift to startup applications by adding a new startup program, naming it Redshift and in the command section put ‘redshift’. Keep in mind, Redshift has a few more problems across all distros I’ve tried. It’s a good app if you configure it properly.

1 Like