Stop Autostarting Apps | KDE | F40

when my machine boots up.

Discover and System settings windows open automatically right after signing in
how can I stop them from starting up automatically?
they are not added in the Autostarts menu in the settings.

2 Likes

Added kde-plasma and removed desktop, nvidia, wayland

Funny, I wanted to open the same thread.

Fedora KDE and Kinoite have a ton of services I also dont need.

  • geoclue
  • xwaylandvideobridge
  • accessibility
  • discover-notifier
  • kde-connect

They are extremely annoying.

The services originate in /etc/xdg/autostart/ and are converted to user systemd services.

systemctl --user should work for stopping these services.

I started a reimplementation if these services into just systemd services which could just be disabled.

That mix is confusing, but disabling them for the user may just work (and be the obvious solution I didnt think of)

Added accessibility, discover, geoclue, sustainability, xwayland and removed kde

Is session restore enabled?, if yes them Plasma is only restarting the applications that were open when you shutdown, close them before that or disable session restore in the settings

1 Like

Nice trick but a dirty workaround and I dont like session restore :smiley:

1 Like