Why isn't Numlock at Plasma Startup turned on by default?

What’s the disadvantage of turning it on by default compared to “Leave unchanged”?

1 Like

With Xorg you have numlockx to force it on. I don’t know what wayland has.

The advantages or disadvantages depends on your personal preferences.

the problem is, I guess, it still doesn’t work

For KDE, there is a setting to turn on num-lock by default. Search for “Numlock” in System Settings.

Courtesy of the Arch Wiki

Go to System Settings > Input Devices > Keyboard, in the Hardware tab, in the NumLock on Plasma Startup section, choose the desired NumLock behavior.

thx, I guess that works but it doesn’t pass the argument to SDDM

https://bugs.kde.org/show_bug.cgi?id=368063

1 Like

Thx. Having a look into the issues about numlock it appears someone also wanting to have it enabled by default 432294 – Numlock is disabled by default on login screen

And here’s a recent bug report 477374 – Plasma on Wayland fails to recognize numlock status on startup

In Fedora 39 Cinnamon, search for numlock yields nothing.