Numlock issue at log in screen (KDE) (F36)

So on gnome after logging in for the 1st time, numlock is on at boot and I can type my password at the login screen (password is numerical using numpad)

Installed KDE to give it a try, at log in screen numlock led is on but cant input into the box.
If I press numlock the led does NOT go off, press it a 2nd time it does, then a 3rd and it comes back on and I can now enter password.

Just done a clean install with Opensuse and at login the led is lit and I can type password, fresh installed F36 KDE again and back to same problem.

A similar thing happend to with Mint Cinnamon, Fedora36 Gnome, and Fedora36 KDE. As in, I have to tripple press Numlock to keep it on. The first only its led turns on, the second off, and the third both its led and its functions turns on.

There is a way in both Mint and in Fedora Gnome to solve this through a GUI, but that doesn’t work in KDE, I think.

Anyhow, I’m looking for a solution too, that is way I came here…

Found it: Settings > Input Devices > Keyboard > Hardware > Numlock on Startup = Turn on.

1 Like