Activating Numlock without physical key on GNOME 44

I just installed Fedora Workstation on my Thinkpad X1 Carbon Gen10 (so GNOME 44.2, Linux 6.3.7-200.fc38.x86_64, Fedora 38). The notebook does not have a numerical keypad but I use a Redox Keyboard which has, among its layers, a numerical keypad. However, it does not have a Numlock key. Previously, I used to run numlockx at startup and never had a problem. Unfortunately, with Wayland this does not work anymore.

I tried the gsettings way, i.e.:

gsettings set org.gnome.desktop.peripherals.keyboard numlock-state true

and tried to both enable or disable org.gnome.desktop.peripherals.keyboard remember-numlock-state

But with no success. I also checked if I can set the numlock key from the BIOS but there’s no option. This is driving me crazy, expecially because I keep typing numbers using the keypad (muscle memory) only to realize that I hit arrow keys or page down, duh!

Do you have any advice on how to solve this?
Thank you very much

I accidentally stumbled upon a solution!
In GNOME tweaks one can enable numpad even with numlock off. Thank god :smiley: