Why CoreOS iPXE need more than 4GiB of RAM to boot

With my test, Fedora CoreOS need more than 4 GiB of RAM when boot with iPXE.

I could understand why Fedora need a lot of RAM to boot, but why CoreOS need even more RAM than Fedora?

I don’t understand this requirement either. I have an older piece of hardware that I wanted to try with CoreOS but with 2G RAM - you can’t. Since then I have run Fedora Server and now Silverblue on it - it’s tight, but works and runs the minimal apps and containers I am testing.

This is currently under investigation in https://github.com/coreos/fedora-coreos-tracker/issues/407. The docs currently recommend at least 3GiB of RAM.

I had missed that the recommended memory min requirement has dropped from 4 to 3G. When I tried a bare-metal install (some months ago) the installer process blocked the installation, even when I suspected it would work - which was frustrating. From the bug #407 discussion it seems that this hard requirement can be side-stepped - for those that choose to live dangerously - which seems like a good approach.

You should be able to get by with 2G of memory if you use the coreos.live.rootfs_url= option. I just tried it and it worked. See https://github.com/coreos/fedora-coreos-tracker/issues/407#issuecomment-709463014