Weird transparent corners on Firefox after upgrading to 38

Hi, I just upgraded to Fedora 38 today, and now the top left and right corners of Firefox are kinda… transparent? Right around the rounded part. When I tile Firefox or expand it and the corners become square the problem goes away. I’ve attached a screenshot with how it looks. Thanks!

Is this a default theme you are using?
Are you on gnome?

For me it looks like a incompatible theme while not displaying the shade.
Similar issue:

Thanks for your reply. I have disabled all theming and extensions, and the issue still appears. I am on Gnome 44.

Did you follow any customization tutorials? It may be that you have run some script to leave the edges rounded, if you have run some kind of script, try to revert, access the places where you left some file that made the modifications to the appearance of FireFox and delete it, a tip whenever you go make customizations, back up the original default file, if something goes wrong, after deleting it, you will put the default files in the proper places that were already fixed as default.