Webex App does not work on Fedora 40, KDE Plasma 6

I downloaded Webex App via Cisco-Website and (manually) installed it. But klicking in the item just opens a “busy” Cursor fro some seconds, but nothing happens then. I tried it on KDE and GNOME (also with Xorg) but alwasy the same. Removing and Reinstallng the app doesn’t change anything.
Does anyone have the same problems and/or knows how to fix that?

Hello,

I have the same problem.

Cisco says that Webex is not supported on Fedora (supported on RedHat 8.2, 8.3).

it was previously working on Fedora although not supported.

Regards,

Hello,

thanks for replying! Alright, I see. Just changed a few days ago from Debian Bookworm, at least it was working with firefoxbrowser (screeshare not possible because of wayland). Now, on Fedora 40 it is even not possible with firefox, just getting a waring that the braowser does not support something. I was not able to get that warning, it’s just there for 2 seconds or so. Do you have experience with that?

Kind regards

1 Like

I’ll try it in some weeks again. Thanks!

Regards

Hello,

I had a similar issue with Fedora 40 upgrading Webex App to version 44.5 and I solve removing library in local folder of Webex App:

rm $HOME/.local/share/WebexLauncher/libWebexVersionSelector.so

In my installation this library has broken dependencies (like libssl.so.1.1), but is already included in the downloaded RPM with the right dependencies.

I hope the trick help you too.

Best Regards

1 Like

A can confirm this, thank you. How did you find that solution anyway?

1 Like

Hello,

I find myself reading Webex logs, using strace and using ldd on libraries in $HOME/.local/share/WebexLauncher/ (strange location for libraries created during Webex update). Finally I see that the same libraries are installed in /opt/Webex/lib and looked up during Webex startup.

Regards

Thanks for replying!
Actually this library doesn’t exist in the recomended path ( $HOME/.local/share/WebexLauncher/...). Did uninstall/remove and installed it again (with actual Downloadpackage). Same issue as described above is prevailing. My “workaround” in the meantime is, attending sessions with the iPad Client :smirk:

Hi,

I find the library after upgrading Webex App to version 44.5 and also after a reinstall of the downloaded RPM from Cisco download page.

Regards

How did you do the upgrade?
I’m just getting version 43.x.x through the website (even if it is telling it is the newest package)?

Regards

Through the app.
I install version 43.x.x through the Website and after a while an available update appears on the interface.

Firefox supports all normal things for video conferences. You might be missing video codecs but thats it. Look at the rpmfusion instructions for libavcodec-freeworld.

Webex is really creepy, they dont seem to care about Linux if not even RHEL 9, Ubuntu 24.04 etc are likely supported.

It is likely that they just want to do shady stuff that Firefox does not allow.

Convince people to use good software, we have BigBlueButton, OpenTalk, Jitsi, Nextcloud meet, Signal, Element and so much more.

If you really need it, try Ungoogled Chromium?

Reference: Reddit - Dive into anything

I tried it and it worked smoothly for GNOME. I think it will also work with KDE.

Added webex

Yes, I found that solution with the Chromium Browser and I’m fine with that. Some teaching stuff at the University uses Webex, so to attend the lectures, I need it sometimes. The CS-Stuff is using BigBlueButton, which I also prefer much more!

1 Like