Warpdrive disconnecting?

Ever since after updating from kernel 6.3.8-200 on fedora 38, my warpdrive disconnects and my whole system locks up until it reconnects, but most of the time it doesn’t.

I don’t actually know that it’s “disconnecting” it just seems that way.

Is this something I need to report as a kernel bug and is there a fix in the mean time?


Do you know for sure that it is the kernel and not, e.g, a bad connection? If you can identify which kernel version introduced the problem (by verifying that is does work properly on earlier kernels), then someone might be able to find the change that caused the problem.

Yes, I can go back to Kernel 6.3.8-200 and everything works great. I haven’t tried the one after 6.3.8, but the other ones for sure have the issue.

My first guess (but this is just a guess) would be that it is probably something to do with power management because I’ve seen that they’ve been working on that part of the kernel recently. I wonder if disabling power management would workaround the problem?

You might try creating a /etc/systemd/sleep.conf.d/override.conf file with the following contents and run systemctl daemon-reload and see if that works around the problem.


I can try that and see what happens.

So far, that seems to have worked. I haven’t had it happen again since I did those changes.

Kind of sucks that my PC won’t sleep on it’s own now though. Lol

That was sort of a “big hammer” approach. But if it is working, it is a pretty good indication that power management is at least part of the problem.

A slightly lighter touch that may or may not work would be to use the following in /etc/systemd/sleep.conf.d/override.conf instead.


See man systemd-sleep.conf for the details about what these settings do.

In any case, you’ve probably narrowed the problem down enough to file a bug report at https://bugzilla.redhat.com/ if you feel up to it.

Edit: See also https://www.kernel.org/doc/Documentation/power/interface.txt

Dang, It just happen again.

No totally hard lock yet though.

I’m pretty much out of ideas beyond disabling power management.

Well, you might check if the driver has any interesting tunables by running modinfo -p <driver name>. You can find the name of the driver being used with lspci -v.