Wacom Pen stops working after some time

Hi, I use a Wacom pen to take notes on my Thinkpad X1 Yoga. Lately the Pen stopped working randomly after like 30 seconds to a minute of writing. I always manage to get it working again after a reboot, only to be met with the same problem over again.

I was able to rollback to an earlier, pinned Silverblue-version, where the Wacom pen works as expected. The difference between the two versions is as follows:

ostree diff commit from: 2332394620d604db12b792645555924b831787667fa0ab09d8558b9a57258bb4
ostree diff commit to:   b82997a74febcead85efc957633e4236da26007503101ec2c1cd0542488c2504
  adwaita-qt5 1.4.1-1.fc35 -> 1.4.1-2.fc35
  btrfs-progs 5.14.2-1.fc35 -> 5.15.1-1.fc35
  cups 1:2.3.3op2-10.fc35 -> 1:2.3.3op2-11.fc35
  cups-client 1:2.3.3op2-10.fc35 -> 1:2.3.3op2-11.fc35
  cups-filesystem 1:2.3.3op2-10.fc35 -> 1:2.3.3op2-11.fc35
  cups-ipptool 1:2.3.3op2-10.fc35 -> 1:2.3.3op2-11.fc35
  cups-libs 1:2.3.3op2-10.fc35 -> 1:2.3.3op2-11.fc35
  fedora-release-common 35-35 -> 35-36
  fedora-release-identity-silverblue 35-35 -> 35-36
  fedora-release-ostree-desktop 35-35 -> 35-36
  fedora-release-silverblue 35-35 -> 35-36
  ibus-typing-booster 2.15.0-1.fc35 -> 2.15.11-1.fc35
  jxl-pixbuf-loader 0.5-3.fc35 -> 0.6.1-6.fc35
  kernel 5.14.18-300.fc35 -> 5.15.6-200.fc35
  kernel-core 5.14.18-300.fc35 -> 5.15.6-200.fc35
  kernel-devel 5.14.18-300.fc35 -> 5.15.6-200.fc35
  kernel-headers 5.14.9-300.fc35 -> 5.15.4-200.fc35
  kernel-modules 5.14.18-300.fc35 -> 5.15.6-200.fc35
  kernel-modules-extra 5.14.18-300.fc35 -> 5.15.6-200.fc35
  libadwaita-qt5 1.4.1-1.fc35 -> 1.4.1-2.fc35
  libaom 3.1.2-1.fc35 -> 3.2.0-2.fc35
  libdav1d 0.9.1-1.fc35 -> 0.9.2-1.fc35
  libjxl 0.5-3.fc35 -> 0.6.1-6.fc35
  libmaxminddb 1.5.2-2.fc35 -> 1.6.0-1.fc35
  nspr 4.32.0-3.fc35 -> 4.32.0-4.fc35
  nss 3.71.0-1.fc35 -> 3.73.0-1.fc35
  nss-softokn 3.71.0-1.fc35 -> 3.73.0-1.fc35
  nss-softokn-freebl 3.71.0-1.fc35 -> 3.73.0-1.fc35
  nss-sysinit 3.71.0-1.fc35 -> 3.73.0-1.fc35
  nss-util 3.71.0-1.fc35 -> 3.73.0-1.fc35
  openssh 8.7p1-2.fc35 -> 8.7p1-3.fc35
  openssh-clients 8.7p1-2.fc35 -> 8.7p1-3.fc35
  openssh-server 8.7p1-2.fc35 -> 8.7p1-3.fc35
  qgnomeplatform 0.8.1-1.fc35 -> 0.8.3-1.fc35
  qrencode-libs 4.0.2-8.fc35 -> 4.1.1-1.fc35
  rav1e-libs 0.4.1-4.fc35 -> 0.5.0-1.fc35
  selinux-policy 35.5-1.fc35 -> 35.6-1.fc35
  selinux-policy-targeted 35.5-1.fc35 -> 35.6-1.fc35
  thermald 2.4.6-2.fc35 -> 2.4.6-3.fc35
  vim-minimal 2:8.2.3642-1.fc35 -> 2:8.2.3717-1.fc35
  virtualbox-guest-additions 6.1.28-1.fc35 -> 6.1.30-1.fc35

I assume the newer kernel is the culprit, but I have no idea how to further troubleshoot or find some meaningful logs for this problem. Any help would be appreciated.

1 Like

I have the exact same issue with the exact same laptop (X1 Yoga Gen. 6). I also recently did the kernel upgrade

kernel-5.14.18-300.fc35.x86_64 → kernel-5.15.6-200.fc35.x86_64

which for me sounds like the culprit as well. I’m on Fedora 35. Any help would be much appreciated from me as well!


Same kernel, same problem on XPS 9310 with Dell Active Pen. Is there a way to revert?

I booted up an older kernel (5.14.18) which solved the issue temporarily. In case you want to switch kernels as well, keep in mind that Fedora hides the GRUB2 menu at boot by default. To display it, do the following:

  • If you use UEFI: hit the ESC-key a bunch of times after you switched on the laptop. The GRUB menu should appear and present you different kernel options.
  • If you use BIOS: hold the SHIFT-key while booting, then proceed as above.
1 Like

I’ve found this issue on Github of the same problem. It also seems like this Github repo is the place to report these things.

As stated in the issue the Kernel 5.15.5 seems to work fine, the problem only starts occurring with 5.15.6.

If you want to keep using 5.15.5, there’s also a Fedora Magazine post about using an older kernel. This should help, at least as a temporary fix.

1 Like