Wacom Problem - Fedora35

Hello, I have a wacom tablet that I use mostly to take notes, that has touch capabilities (it works like a touchpad).
For some reason when the tablet is plugged in everything works fine, but when I connect it by bluetooth the writing / drawing gets really awkward.
In other words, when the tablet is plugged in, it seems that the touch function is disabled as long as the pen is near the tablet. And when on bluetooth, it just goes berserk.

Also, I tried to recreate this problem with Ubuntu and I could not.
I am really considering moving to Ubuntu because of my classes :frowning:
So I am trying to understand if there is a way to fix this, as I love fedora more than Ubuntu :stuck_out_tongue:

Thanks all

Did you give a try to search about Bluetooth? We do also have some cases about this wacom tablets, did you search about it?

Did you try with an older kernel?

If you have some more questions here, we would definitely need more info about hour hardware:

inxi -Fzx in terminal and post the output as </> Preformatted text here.

Thanks for your answer.
I tried to search as much as possible, and even posted a query in the libwacom page, altough no one has answered yet. About kernel versions, I am not so sure, but I can guarantee this was not working on fedora 34 (and I think kernel version has changed since - I am still a noobie in what concerns these topics).

I have tried to reproduce the problem in Ubuntu and Mint, and both are working fine. So I thought it could possibly be Fedora related? When plugged in it works fine too.

Here is the output of inxi -Fzx

  Kernel: 5.14.18-300.fc35.x86_64 x86_64 bits: 64 compiler: gcc v: 2.37-10.fc35 
  Desktop: GNOME 41.1 Distro: Fedora release 35 (Thirty Five) 
  Type: Laptop System: ASUSTeK product: ZenBook UX534FTC_UX534FT v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: UX534FTC v: 1.0 serial: <filter> UEFI: American Megatrends 
  v: UX534FTC.304 date: 12/16/2019 
  ID-1: BAT0 charge: 55.6 Wh (92.7%) condition: 60.0/71.0 Wh (84.5%) volts: 15.8 
  min: 15.8 model: ASUSTeK ASUS Battery status: Discharging 
  Info: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check rev: C cache: L2: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36799 
  Speed: 800 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 800 2: 2363 3: 1375 
  4: 825 5: 1060 6: 900 7: 900 8: 900 
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: ASUSTeK driver: i915 
  v: kernel bus-ID: 00:02.0 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK 
  driver: nouveau v: kernel bus-ID: 02:00.0 
  Device-3: IMC Networks USB2.0 HD IR UVC WebCam type: USB driver: uvcvideo 
  bus-ID: 1-5:5 
  Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting 
  unloaded: fbdev,vesa resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.5 
  direct render: Yes 
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus-ID: 00:1f.3 
  Sound Server-1: ALSA v: k5.14.18-300.fc35.x86_64 running: yes 
  Sound Server-2: PipeWire v: 0.3.40 running: yes 
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel 
  port: 4000 bus-ID: 00:14.3 
  IF: wlo1 state: up mac: <filter> 
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-10:7 
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
  Local Storage: total: 953.87 GiB used: 8.82 GiB (0.9%) 
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB 
  temp: 23.9 C 
  ID-1: / size: 952.28 GiB used: 8.61 GiB (0.9%) fs: btrfs dev: /dev/nvme0n1p3 
  ID-2: /boot size: 973.4 MiB used: 202.4 MiB (20.8%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-3: /boot/efi size: 598.8 MiB used: 13.8 MiB (2.3%) fs: vfat 
  dev: /dev/nvme0n1p1 
  ID-4: /home size: 952.28 GiB used: 8.61 GiB (0.9%) fs: btrfs 
  dev: /dev/nvme0n1p3 
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0 
  System Temperatures: cpu: 44.0 C mobo: N/A gpu: nouveau temp: 34.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 320 Uptime: 2m Memory: 15.42 GiB used: 3.64 GiB (23.6%) 
  Init: systemd runlevel: 5 Compilers: gcc: 11.2.1 Packages: 11 note: see --pkg 
  Shell: Bash v: 5.1.8 inxi: 3.3.06

What is the Wacoms exact model ?

It’s a Wacom Intuos Pro medium model PTH-660.


Since your config says you’re using X (and not Wayland), you can use the command xsetwacom to set the wacom tablet options. Use

man xsetwacom

to see what you can do.

Note that options you set via xsetwacom are not persistent. If you find an option that solves the problem and want to make it permanent, you need to make a config file and put it in /etc/X11/xorg.conf.d

If the going beserk you describe only occurs when you try to use the tablet, it could be that touch is not deactivated properly when using the tablet via bluetooth. If you don’t care about touch (and since you use it for notetaking, I assume you don’t), you can try

xsetwacom list devices

to get the device-name of your tablet, then

xsetwacom [device-name] set Touch off

You can try other options using xsetwacom if that doesn’t work.

However, since it works under Ubuntu, it’s almost certainly a kernel issue. Check out


for how to install an old LTS kernel on Fedora. (Note kwizart is a Fedora maintainer so his COPR should be trustworthy.)

Hey Jonathan, thanks for your detailed reply.
I have checked the manual, and compared the output of each device when connected by bluetooth and by usb, with the command xsetwacom get "device id" all.
When connected by bluetooth a fourth device appears with the name cursor. I will check ubuntu to try to determine if the issue comes from this “device”. For the other three devices, the output is exactly the same when connected by bluetooth and usb.

Unfortunately what I really wanted was for the touch to work without having to carry too much stuff around. Even if I take the cable, whenever I have to move the laptop I have to take the tablet with me. It shouldn’t be a must.

I’ll be sure to check the lts kernel.

Thanks for your kind answer, all the best!