Error Bluetooth | Cambridge Silicone Radio Bluetooth Dongle | Kernel 6.0.x

Greetings, I have been with fedora36 for 6 months and the bluetooth worked perfectly and 2 days ago it stopped working. When I try to connect it, everything flashes or it recognizes it, but ignores it completely. I have already tried on other devices and the bluetooth works fine. Any ideas?

Welcome to ask.fedora @edarcode

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

If you not had time yet please also read #start-here

I have no idea what you’re talking about, maybe I’ve resigned myself, thanks for answering. I thought it would be easy to fix. It seems it only works on windows and no linux grabs. Although it’s super weird because it worked fine until 3 days ago T.T

Your information you gave is not enough, just saying it not works anymore and it works on windows is not enough info that we can help you.

So please again
Open a terminal and copy paste the command inxi -Fzx in it. You will get a list of information.
Please copy and paste the info the tool displays in the terminal and post it here as </>pre-formatted text.

If you want help here, you have to be able to make a useful question and be able to deliver information so that we can help!

It is not wierd, the kernel changed and it could be that your hardware is not recognized with the new kernel yet. So if you want that it works in future you should give necessary information.
That’s how opensource works !

Did you get a try, when booting pressing shift, so that you can choose the older kernel (5.19.16-200.fc36.x86_64)?

If it works please do inxi again and post the part of bluetooth again to see if it uses same driver etc.

You really want to make things complicated right … i not saw which kernel you use!

And what are you looking for here? That someone explains you everything about Linux?
Sorry we are not a free Baby-Sitting service here. We do invest our free time here to help people who are open and willing to learn new things. But this means you have to do your part to give us the information we asking for …

When I do write inxi -Fzx as preformatted text then it looks like this way (It is my info!):

  Kernel: 5.19.16-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-36.fc36 Desktop: GNOME v: 42.5 Distro: Fedora release 36 (Thirty
  Type: Laptop System: CompuLab product: Intense-PC v: 1.x
    serial: <superuser required>
  Mobo: CompuLab model: Intense-PC v: 1.x serial: <superuser required>
    UEFI: Phoenix v: IPC_2.2.400.5 X64 date: 03/15/2018
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse charge: 55%
    (should be ignored) status: discharging
  Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard charge: 55%
    (should be ignored) status: discharging
  Info: dual core model: Intel Core i7-3517UE bits: 64 type: MT MCP
    arch: Ivy Bridge rev: 9 cache: L1: 128 KiB L2: 512 KiB L3: 4 MiB
  Speed (MHz): avg: 799 high: 800 min/max: 800/2800 cores: 1: 798 2: 800
    3: 800 4: 798 bogomips: 17559
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
    arch: Gen-7 bus-ID: 00:02.0
  Device-2: Sunplus Innovation FHD Camera Microphone type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 3-2:2
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.4 driver: X:
    loaded: modesetting unloaded: fbdev,vesa dri: crocus gpu: i915
    resolution: 2560x1080~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa
    22.1.7 direct render: Yes
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 3-2:2
  Device-2: Sunplus Innovation FHD Camera Microphone type: USB
    driver: snd-usb-audio,uvcvideo
  Sound API: ALSA v: k5.19.16-200.fc36.x86_64 running: yes
  Sound Server-1: PulseAudio v: 15.0 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
  Device-1: Intel 82579LM Gigabit Network driver: e1000e v: kernel port: 4080
    bus-ID: 00:19.0
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter vendor: AzureWave
    driver: rtl8192ce v: kernel port: 3000 bus-ID: 04:00.0
  IF: wlp4s0 state: down mac: <filter>
  Device-3: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169 v: kernel port: 2000 bus-ID: 06:00.0
  IF: enp6s0 state: down mac: <filter>
  IF-ID-1: br0 state: up speed: 1000 Mbps duplex: unknown mac: <filter>
  Device-1: IMC Networks type: USB driver: btusb v: 0.8 bus-ID: 1-1.3:3
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 232.89 GiB used: 120.18 GiB (51.6%)
  ID-1: /dev/sda vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB
  ID-1: / size: 231.22 GiB used: 119.95 GiB (51.9%) fs: btrfs dev: /dev/sda3
  ID-2: /boot size: 1004.8 MiB used: 220.9 MiB (22.0%) fs: ext4
    dev: /dev/sda2
  ID-3: /boot/efi size: 574.8 MiB used: 13.9 MiB (2.4%) fs: vfat
    dev: /dev/sda1
  ID-4: /home size: 231.22 GiB used: 119.95 GiB (51.9%) fs: btrfs
    dev: /dev/sda3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 52.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 277 Uptime: 51m Memory: 15.05 GiB used: 2.73 GiB (18.1%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.2.1 Packages: 17
  note: see --rpm Shell: Bash v: 5.2.2 inxi: 3.3.22

See on the top …
Kernel: 5.19.16-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
v: 2.37-36.fc36 Desktop: GNOME v: 42.5 Distro: Fedora release 36 (Thirty

Your screenshot not shows this information !

Yes, ok again here with fedora we do follow the schedule of the official kernel. You can find information about it on

On the third line of this list you see stable: 5.19.17 [EOL] 2022-10-24
EOL means End of Live! The new stable kernel 6.0.7 not has the drivers included or does not recognize it yet.

To prepare your system to a new kernel release you can test your hardware before EOL and use the rawhide or the beta version to see if you are ready for the next stable kernel.

If you not are aware of such information, it is not our fault if you cant use your system as with windows. It is up to you to get into this knowledge and start to act as an adult opensource user who also contributes back with information to make thins work in future kernel releases.

thank you, you are very kind

Saying you are a windows user who wants to switch is not enough. Especially when you refuse to follow instructions on how to help us to help you.

You were asked to open a terminal window and run specific commands, yet your response is I have no idea what you’re asking me. TWICE. This tells me you are failing to even consider that others may be able to assist but that assistance comes with the necessity of you following instructions to provide the information requested.

Please follow instructions and post the results of the requested commands here so we have the needed information to provide assistance.

1 Like

Hmm, after a complete update the output in the terminal of

systemctl status bluetooth

would be helpful to see what is wrong. But for that the system would have to be up to date. Otherwise it is not solvable.
Inxi is only there to read the hardware better and to have everything clearly.

1 Like

Thanks, I managed to solve the problem. my intention was to convey an idea. I didn’t think they would bother. I expressed it in such a way because in my work it is possible to have an idea of the possible problem without going to the extreme. Regarding the commands, I did what he asked me to do, only when he asked me for more things I chose not to do it, since I considered that it was not worth going over there if something as simple as having audio was so complex.

Is it possible to delete this topic? I can’t find the button to close or delete the main post

Normally we do share information. So if you have a solution please let us know and mark it as a solution.

If you want to edit your request you should be able to do so. If I have something that you like it should disappear, you can even tell me what in a personal PM, im open. My intention was not to offend someone. It is just strange, that I do even offer my help on Weekends, try to gather information and find a way to help. And in the end ppl. want to delete their request just because of silliness ?

I see that it looks bad for your fist Topic. Why you not start over and give it a second try?

“Err bluetooth” is just quite nothing to help you with. Then after the Title you have set just one tag.
I missed if you use Gnome, Kernel version and a bit more complex error message.

Reading #start-here already gives a lot of information how a useful topic should look like.

And here you have some ideas how we normally do like to communicate with each other.

The error was fixed by changing the kernel at login. I want to delete or close what has already been discussed so that I don’t have to receive messages that I find somewhat offensive. I don’t know about you, but it’s annoying when they start treating you like a fool or lazy when you ask a question in a forum. It’s nothing personal, I guess all the people who know more than others are like that.

The topic can be ended if you mark the solution. At that point most will read it but no longer respond.

There is no requirement that you respond to anything you feel is offensive. If you are sensitive enough that a comment by someone trying to help feels offensive then you should consider if it is actually meant to be offensive or if you may be reading something in that was not actually meant. PMs are a good way to express feelings to individuals that you find offensive rather than blasting everyone on the forum, and stating what you find to be offensive in that way will mostly get the user to edit their post to not be offensive.

In general, the discussions here are intended to be ‘Excellent to Everyone’ and all try to follow that guideline.