Volume set too low for external speakers after every reboot

Fedora version : 30
Linux version : 5.0.17-300.fc30.x86_64 (updated on 28-May-2019)

My laptop model : HP Omen purchased on 2018 November
My external speakers : Logitech external speaker with subwoofer (Model: Z625)

I attach external speakers to the headphone out of my laptop. It works fine with my Windows 10 (dual boot).
But, whenever I restart my laptop , the volume for the external speakers are set too low.

Below are the few things, I have tried to fix this:

Using alsamixer, I increased the volume of ‘Speaker’ (external speaker, ) bar and tried to permanently store the setting using store command shown below. Although it increases the volume of external speakers , the settings are lost upon reboot of the laptop.

> sudo alsamixer
sudo alsactl store

I mean, whenever I restart the machine, in the alsamixer, I can see that ‘Speaker’ bar (external speaker) is set to zero.

Screenshot below (see the third bar from the left which is empty)

b) Tried installing pulse audio equalizer. Didn’t help
c) Tried installing pulse audio equalizer shortcut thingy. Didn’t help.

d) Installed pavucontrol like below. pavucontrol is pulse audio control. It gave a control panel. But, I still cannot permenantly set the volumne for external speakers.

dnf install pavucontrol

Sound card details:

[root@localhost sysadmin]# grep Codec /proc/asound/card0/codec#0
Codec: Realtek ALC295
[root@localhost sysadmin]#

Output from # lspci -v

> 00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
	DeviceName: Onboard - Sound
	Subsystem: Hewlett-Packard Company Device 846a
	Flags: bus master, fast devsel, latency 32, IRQ 154
	Memory at aa218000 (64-bit, non-prefetchable) [size=16K]
	Memory at aa100000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [50] Power Management version 3
	Capabilities: [80] Vendor Specific Information: Len=14 <?>
	Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel, snd_soc_skl
1 Like

I managed to fix this issue by following the steps mentioned in the below link

Step1. Install alsa-tools.
Step2. Run hdajackretask utility in the terminal and the below shown GUI thing will come up.
Step3. Under ‘Black Headphone, Left side’ Pin ID: 0x21, select the Override check box.
In the drop down list, select Internal Speaker

Step4. Click on Install Boot Override (Mandatory step)

Step5. Reboot machine.

But, I have absolutely no idea what this does. But, it fixed the issue. Anyone here has any clue on this ? If this audio issue was not fixed, I was planning to move to Ubuntu. :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.