Sound issues in Fedora 33 KDE spin

Since a couple of days ago, I’ve been having sound issues on one of my machines. The machine in question is a Thinkpad P51, and the issue I’m having is that whenever I plug in or unplug anything from the audio jack, all of my audio channels are both muted and have their volume set to 1%. This would be a minor annoyance in and of itself, but to make it worse, my system is showing a 2nd headphone device that I can’t see anywhere except alsamixer. This device can be muted, and does mute whenever I plug/unplug anything, but has no volume control. If it is muted, I get no sound on whatever is plugged into the 3.5mm jack, and it doesn’t unmute when I unmute the headphones from pavucontrol or the Plasma audio control widget. I haven’t found any way to unmute it without going into alsamixer. I have other systems on fedora which do not suffer from this issue, and it only began on Friday night. I hadn’t installed any updates for a couple of days, but that also may have been the first time I unplugged my headset since the most recent update, so the update could be to blame.

I have tested my headset on other devices to verify that it works, and if I boot the Fedora KDE installer from USB, everything works normally in that environment, so I can be fairly sure that it is not a hardware issue. I’ve tried disabling pulseaudio, and I’ve tried booting to every older kernel I still have on my boot menu, none of which solved the problem. So I have to assume that I’m hitting a bug in some package that I have installed, or that an update changed a configuration somewhere, but as yet, I haven’t managed to track it down. Does anybody have any ideas or suggestions what might be causing this issue or how to further troubleshoot it?

You could try a dnf history to track this down. Downgrade and lock it see here:

Thank you for the suggestion. However, I have found a solution to the problem :slight_smile:

What ended up fixing it was to edit the files /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones-2.conf and commented out every line in the [Element Headphone] and [Element Headphone2] section. I also edited /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf and commented out all the lines in the [Element Speaker] section. After rebooting, everything was working as expected again, with audio switching between headset and speakers when I plug/unplug the headset.

I’m not entirely sure all of the edits I made are necessary, but once it was working, I didn’t really want to go back and keep messing with it to find out.

It’s not worth. Fedora 34 brings the solution for most audio problems: