Using Origin to play The Sims 4/Other Origin games


I’m trying to setup Origin via Lutris on Fedora.
I started with the Lutris beta from Flatpak which manages to install but once I try to run The Sims 4 I get an error regarding VC++ runtime not being available.

I’ve also tried layering the package via rpm-ostree but when running the origin installer script the window to confirm installation of geko(?) is basically just the window borders which I can’t resize and this prevents the installation.

Has anyone managed to get this working or other origin games working on Fedora?

Note: I’ve had no issue with the installation when using Lutris on Ubuntu 20.04.

I gathered some information regarding Origin and TS4 from /r/wine_gaming, though I don’t own the game so I can’t really attempt to reproduce this.

If your not facing any other issues with it, I’d suggest reverting back to using the Lutris Flatpak just so as to avoid needlessly layering stuff using rpm-ostree.

First things first. How did you install the game?
Did you use the installation script for The Sims 4 from Lutris.
Was it the generic Origin installer or maybe no installer at all (manual config).

The scripts uploaded seem to install different deps, so I’ll just take a shot in the dark based on the stuff I found on Reddit.

Right-click the game entry in your library > Winetricks > Install a Windows DLL or component.
Install vcrun2019.
Then, according this post, it seems like you’ll need to disable Origin’s overlay twice!

Origin > Application Settings > Top menu bar “ORIGIN IN-GAME” > Turn off “Enable Origin In-Game”
In the left vertical menu activate “My Game Library” > right-click on the Sims 4 game cover and select “Game Properties” > Turn off “Enable Origin In Game for The Sims…”

In case the problem persists, try grabbing the games logs.
They should be able to help nail this one.

1 Like

Thanks for your response, unfortunately I have tried manually selecting vcrun2019 (and also 2010 and 2013 which from Origin I understand the sims uses) but I still can’t get it to work. I’m thinking it must be an issue with the runtimes provided by the Flatpak so will file a bug report.

On the bright side I’ve realised my error trying to layer Lutris is that rpm-ostree doesn’t support x86 libraries. I have now got it working from a toolbox!