Fedora Silverblue 35 - Lutris flatpak problem with GPU drivers?

Hello, i’m trying to run a game on my laptop with AMD CPU 5600H and GPU RX 6600M with the open-source drivers, but for some reason I’m getting DX11 error in FFXIV whatever I do - I’ve tried running the game with the default runner, fshacks and ge-proton (older versions too) but it’s always the same error:

An unexpected error has occurred. Exiting FINAL FANTASY XIV.


Would anyone have any idea why this is happening?
Here are the crash logs: FFXIV - Pastebin.com

To me that looks like it expects a windows file (ffxiv_dx11.exe) that probably does not work in linux.

You have not told us anything detailed about your hardware, software, how you are running the game, whether it is the windows version or linux version, if you are using steam or running it another way. Thus we have no detailed info about the problem to assist.

1 Like

I used to run the game in flatpak Steam via Proton, but a recent update broke Linux compatability (the game itself runs very good, but the new launcher doesn’t work on Linux) so the only workaround for now that I know of is to use a third-party launcher via Lutris.
I installed the launcher via flatpak Lutris and pointed it to the already installed game under flatpak Steam so I don’t have to download ~80 GB again. In Lutris I tried running it with wine, ge-proton, fshacks - the game itself launches with no issues but the error mentioned in my first post always appears when I press Start at the start screen in-game (the Start button leads to the character selection screen).

Here’s the harware info from Lutris, my OS is Fedora Silverblue 35:
OS: GNOME 41 Flatpak runtime
Arch: x86_64
Kernel: 5.16.15-201.fc35.x86_64
Desktop: GNOME
Display Server: wayland

Vendor: AuthenticAMD
Model: AMD Ryzen 5 5600H with Radeon Graphics
Physical cores: 6
Logical cores: 12

RAM: 15.1 GB
Swap: 8.0 GB

Vendor: AMD
OpenGL Renderer: AMD RENOIR (DRM 3.44.0, 5.16.15-201.fc35.x86_64, LLVM 12.0.1)
OpenGL Version: 4.6 (Compatibility Profile) Mesa 21.3.6 (git-fef2cdb0a5)
OpenGL Core: 4.6 (Core Profile) Mesa 21.3.6 (git-fef2cdb0a5)
OpenGL ES: OpenGL ES 3.2 Mesa 21.3.6 (git-fef2cdb0a5)
Vulkan: Supported