Users not listed after a reboot by a button

Hi everyone! After performing a reboot by a button, not by sudo reboot my user account does not listed in screen which provided below. How can i fix this? Ctrl + alt + f6 working, but classic commands seems to does not work there.

I don’t have such a problem in f36, dont know what caused this in my f37.

Do you have multiple displays connected?

You may want to take a look at journalctl -u gdm

Welcome to ask :fedora: @addmix please take a minute to


Yes, I do. But if I unplug them, it won’t help. I would love to try your answer, but how can I access terminal from such state?

Ctrl + alt + f6 working, but classic commands seems to does not work there.

Apologies I missed this part. Can you elaborate on this a bit?
Is there an error when you try to run a command?
Does it do the same for F2, F3 ?

After you get back to a working graphical session:
to show the logs from the previous boot, journalctl -b -1
journalctl --list-boots will give you a list of boot numbers relative to the current one, 0 being the most current. You can also use this number to go back to a boot where you had the issue.


Ctrl Alt F6 combination let me type the command, but i can’t see any output afterwards. This is not okey, right? The output must be working in one of Ctrl + alt + f buttons combination?

Maybe there is a way to access via root user of somekind and then do all the rest manupulations?

Are you running an NVIDIA card?

If you sudo reboot can you login?

Yes, Nvidia RTX 3050 Laptop. Sudo reboot on crtl alt f buttons does not work.

For myself and others there seems to sometimes be a glitch in properly updating the nvidia drivers. For me it happened when I upgraded my laptop from 36 to 37.

That thread may lead you to the solution by removing then reinstalling the nvidia drivers.

1 Like

Is it ok that when i try to remove nvidia drivers by following command: sudo dnf remove '*nvidia*' --exclude=nvidia-gpu-firmware it gives me an error:

The operation would result in removing the following protected packages: kernel-core
(try to add ‘–skip-broken’ to skip uninstallable packages)

If i try to add --skip-broken it also did not worked

Please post the output of dnf list installed '*nvidia*'

There is not a reason that I am aware of where it should attempt to remove any of the kernel packages when the nvidia drivers are installed from rpmfusion.

Installed Packages
nvidia-gpu-firmware.noarch              20220913-140.fc37              @anaconda

Found this article:
Would it be okey to install Nvidia Drivers from RPM Fusion repository on fresh system? In this article author says that this will disable noevau drivers automatically.

It is absolutely OK to do that.
From the gnome software panel you have an option to enable 3rd party repos. If you have not already done so then enable them.

Next, from a terminal window run
sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda.
This will install all the necessary packages.
Wait about 5 minutes (or a little more) then reboot.

Just as an FYI you also need to have secure boot disabled before the nvidia drivers can be loaded. (Or you need to enable signing of the modules before running the command above to install them if you wish to have secure boot enabled).
If you wish to have the modules signed follow the instructions at\bCategoryHowto\b)
or at /usr/share/doc/akmods/README.secureboot

You might need to run sudo dnf install akmods before you can enable signing of the modules.

1 Like

I literally done one reboot, only one after installing fresh system. And then agagin, i can’t access to my system. I planned to install Nvidia drivers after updating all the rest. Now kernel remove take place right?

the output of dnf list installed *nvidia* showed the drivers are not installed so the remove should not be tried again.

You should log in, install the nvidia drivers, then reboot as per the steps above. It is known that the nouveau drivers do not presently support the GTX 3050 GPU.

You stated above that you can log in with crl-alt-F6 so log in that way and install the drivers before you do anything else.

It really helped, thank you!!! Works just perfect.