Broken Nvidia propeprietary drivers, Fedora 37

After installing nvidia proprietary drivers by this topic: Users not listed after a reboot by a button - #6 by addmix eventually they got broke again. I presume it’s because of incorrect kernel update. Now, once again a can’t access to normal griphics mode. Virtual terminal does not show up as well. Not to mention now i get my self 2-3 minute boot time.

Maybe there is way to boot without graphics or low graphics mode? I wish to reinstall/fix my driver without complete system reinstall.

I have a Dell G15 5510
Nvidia RTX 3050 + Integrated gradhics card.

We don’t know exactly what you see when you cannot boot.

However, if you can get the grub menu to display then you should be able to select an older kernel that did boot properly and boot with that.

Once booted it is not super difficult to recover. Let us know if you can boot to an older kernel and we can then step through the repairs.

One critical thing to remember is that when doing an upgrade it is very important to always allow the upgrade to complete and the prompt to return before doing anything else. Then wait an additional 5 to 10 minutes after the upgrade completes before rebooting. This is time required by the system to build the new kernel modules for an upgraded kernel and drivers.

If a choose older kernel, this message appears: “Nvidia kernel is missing, falling back to noevau” and symptoms are the same:

The most dissapointing thing, is that once again i cant access to teminal and provide some logs or more detailed information.

Something like this, i suppose:

Sorry- removed - won’t do any good for reinstallation nvidia

So, is there any chance to workaround this?

You can start in non graphical mode as follows:

When you get to the grub menu (with the correct entry selected) press e which lets you do one-time edits to that entry. Navigate to the end of the line that starts with linux and add 3 (space and 3) to the end, then press either F10 or ctrl-X

Once you have started in non graphics mode, you can log in and reinstall the Nvidia driver. There are different things you could append to that line if logging in is an issue (you can make it comes up already root, rather than requesting log in): search for instructions for resetting the root password.

The 3 is a shorthand for a more complicated incantation. Online instructions advise to use the full incantation rather than the 3. In some future version that might make a difference. But for now using just the 3 works fine.

Thank you! I booted in non graphical mode and perform the following procedure:
Unfortunately, even this won’t help this time. At least at non-graphics mode i can acess to logs.

I look at journalctl -u gdm and found several erros, such as:

  • gkr-pam: unable to locate deamon control file
  • Gdm: Failed to list cached users: GDBus.Error:org.freedesop.Dbus.Error.NameHasNoOwner
  • gdm.service: Failed with resuklt ‘exit-code’

Anyway, now i’m available for debugging.

@computersavvy can you please help me if i provide you some logs or outputs? I assume this time nvidia drivers is not the problem, something else happened.

I do have a little time right now. Can you give an update as to the current situation so we have a starting point to work from.

1 Like

I managed to get access to the system via no-graphics mode. Thanks to that, i reinstalled nvidia drivers by your instructions. Unfortunately, this time it’s not the case. Users still not listed in the graphics-mode.

I noticed a lots of error like unable to enumarate usb device, usb descriptor errors during booting and shutting down. Also this Gdm: Failed to list cached users: GDBus.Error:org.freedesop.Dbus.Error.NameHasNoOwner strange error.

Maybe the best way to fix - once again reinstall system, but install drivers in no-graphics mode.

That sounds like an unrelated problem that you might ignore or might want to look into later.

That sounds like THE problem.

That Gdm problem certainly sounds like one that could be solved by a reinstall. That seems like an excessively drastic solution to me. I expect there is some simple config file that could be delete or edited to fix the problem (nano is a good non-gui editor for those of us who only know how to use gui editors).

I don’t use Gdm, so I can’t guess what config file(s) to fix. So hopefully you get a better answer soon. Meanwhile I think reinstalling should work but shouldn’t be needed.

From many painful experiences that needed reinstall of drivers for old Nvidia cards (or other corrections needed due to those cards), I can tell you for certain that in some of those situations you can get to a terminal that way after a failed attempt at launching the GUI and in some you can’t. When that method of getting to a terminal fails, you need to know how to get directly there from grub (which I hope I explained correctly in an earlier post in this thread). Sometimes the terminal only works if you have not yet tried to start the GUI.

For the USB errors the starting point is to disconnect all usb devices while booting then reconnect them one at a time to see if one can identify which is triggering the errors.

The dbus error is beyond my expertise.

One should always be able to use ctrl-alt-F3 (or F4, F5 or F6) to open a text login screen after the boot has completed. That should allow installing drivers or other packages needed without the graphical DE available.

Totally agree, not to mention that i already performed 3 reinstallains, so it’s just a temporary fix anyway.

Hope i find this config, so i can share the solution.

Or probably there is a dnf command to clean up a corrupted install of gdm without reinstalling the whole system.

I’m expert in some aspects of this and a hopeless beginner at others. dnf is not one of my areas of expertise, but Jeff V should certainly know.

I decieded to check my strationary PC, which also runs by Fedora and this is jourantctl -u gdm:

Feb 21 22:10:23 mikhail-pc-linux systemd[1]: Starting gdm.service - GNOME Display Manager...
Feb 21 22:10:23 mikhail-pc-linux systemd[1]: Started gdm.service - GNOME Display Manager.
Feb 21 22:11:24 mikhail-pc-linux gdm-password][3777]: gkr-pam: unable to locate daemon control file
Feb 21 22:11:24 mikhail-pc-linux gdm-password][3777]: gkr-pam: stashed password to try later in open session
Feb 21 22:11:30 mikhail-pc-linux gdm[1553]: Gdm: Child process -1708 was already dead.
Feb 22 00:13:40 mikhail-pc-linux systemd[1]: Stopping gdm.service - GNOME Display Manager...
Feb 22 00:13:41 mikhail-pc-linux gdm[1553]: Gdm: Failed to list cached users: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not activate remote peer: activation request failed: a >
Feb 22 00:13:41 mikhail-pc-linux systemd[1]: gdm.service: Main process exited, code=exited, status=1/FAILURE
Feb 22 00:13:41 mikhail-pc-linux systemd[1]: gdm.service: Failed with result 'exit-code'.
Feb 22 00:13:41 mikhail-pc-linux systemd[1]: Stopped gdm.service - GNOME Display Manager.
Feb 22 00:13:41 mikhail-pc-linux systemd[1]: gdm.service: Triggering OnFailure= dependencies.
Feb 22 00:13:41 mikhail-pc-linux systemd[1]: gdm.service: Failed to enqueue OnFailure= job, ignoring: Transaction for plymouth-quit.service/start is destructive (lvm2-monitor.service has 'stop' >

So, as you can see there are the GDBus error, but on stationary PC Fedory boots so quickly, that i even can’t spot loading screen. Basicly logs on laptop the same, except gdm-password loss. Maybe this is the problem, the accountService. I tried to reinstall accountService but no effect.

On my laptop gdm-password logs does not exist, also the following output by gdm during startup:

Tried to look up non-existent conversation gdm-launch-environment
Freeing conversation ‘gdm-launch-environment’ with active job

A quick google search found this:
Which has the same gdm-launch-environment issue you describe and the solution that a theme had been broken (fixed by deleting the whole broken theme). Could that fit your situation?

1 Like