Stuck on boot after fresh install fedora cinnamon

I’m new on fedora and I have post install problems.

I’ve installed Fedora cinnamon (my favorite DE) without a hitch, but the first time I launch it, I only see the initial system configuration page for half a second, and I get this message

And when I force the reboot, I get to lightdm, I enter my password, and I get a black screen… I can’t do anything more.

I’m having so much trouble that I’ve tried several spins.

The problem is the same with Xfce, but not with KDE or gnome.

I almost switched to one of the latter DE because I’m fed up with the hassle, but they really don’t suit me at all…

Any ideas?

Welcome to Fedora @pantoufle.

Looks like a problem with your Videocard. Can you please tell which Version F38 or F39 Beta you are testing?

F38 version, and my graphic card is a GeForce RTX 3060

Try press F2 or above to login when you get the black screen. Is this possible? You should get a text terminal to log in.

When you do a fresh install, before rebooting, do you give a bit time that the Nvidia drivers can be actualized/installed correctly?

Can you please follow this instructions:

Can’t have access to the terminal. F2 doesn’t work.

Yes I give time after install, I even update everything

Did you also install the nvidia drivers from rpmfusion?
The nouveau driver (default in fedora) does not properly support the newer nvidia GPUs.

How could I ?

Can I install the nvidia driver and/or update everything on the liveUSB before starting the install process ?

The system should install properly if you select the ‘troubleshooting’ link on the initial screen then select to use ‘basic graphics’ on the next screen.

After the install completes it hopefully would allow you to do the initial setup to create your user and enable the 3rd party repos.

Following that you should be able to use ctrl-alt-F2 or ctrl-alt-F3 to connect with a text screen then use dnf to install the nvidia drivers (dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda)

You also can get to a text command line in single user mode (as the root user) by editing the grub menu commands to remove ‘rhgb quiet’ and add ‘/bin/bash’ on the line that begins with ‘linux’

I have no troubleshooting option.

I can chose to start fedora with the lasr kernel or to start it in rescue mode but it also ends on a black screen after connecting to my session in lghtdm.

Doesn’t work either in rendering mode

Can you boot from the install live media?

If so then it is possible to walk through the steps to mount the installed partition and use chroot to have access to that file system & OS to install the nvidia drivers.

Let us know what is currently possible to get a running system with a functional display on the system, Then the steps can be designed to facilitate recovery.

Ok, I’ll check if I have any access to the filesystem but I’m already pretty sure that I can boot on a liveusb.

Thank you both very much for your help


I’ve finally made fedora cinnamon work, in a simple way !

I reinstalled fedora cleanly. It bugged again on the first boot, when the initial configuration showed up.

I rebooted, and when I was on lightdm, I simply opened a terminal (ctrl + alt + F2) and did sudo dnf update, a reboot, and everything worked…

I haven’t identified which update solved me but I can finally use fedora…

Thank you all for your help!

1 Like