Load/Save rfkill status stuck, nvidia driver issues

Right, hello,
yesterday I installed fedora 35 on my main computer - Lenovo ThinkPad P50 with I7 and Quadro graphics.
Right after installation I encountered some issues:
I have an external monitor connected to the laptop and nouveau drivers really cannot handle this very well - I encountered occasional system freezing, etc., so I installed proprietary drivers by nvidia instead of nouveau (https://www.linuxcapable.com/how-to-install-the-latest-nvidia-graphic-drivers-on-fedora-35-gnome-41/ – tutorial, worked just fine). Everything was fine but the next day when I tried to boot to the system, it got stuck at [OK] Load/Save rfkill status → THIS WAS THE 5.17.whatever kernel
There is another kernel installed 5.14 and I could boot there normally, however, I got back the nouveau drivers (the nvidia were not even available)… Do I need to install them again?

Any help would be very welcomed, brill thanks!!

Yes, kernel modules must be installed for each kernel version that you want to use. Normally a package of modules will install itself for all kernel versions that are installed, but that may not have happened in your case.

1 Like

When you say ‘it got stuck’ that is subject to interpretation. I might think it was stuck with a 3 hour hang, while you may think it was stuck with a 1 minute hang. Exactly how long did you wait before you forced a reboot?
I have had systems that seem to ‘hang’ for sometimes more than 5 minutes while the new kernel modules are being built and loaded when installing the nvidia drivers and others.

Have you tried booting into that 5.17 kernel again?

Have you done the normal sudo dnf upgrade step to ensure the system was 100% up to date with the repo then tried rebooting again?

1 Like

Thank you for clarification.

Fair point. I waited for 4.5 hours…
Yes, I tried booting back again and successfully. There are some caveats:
If I turn on the external monitor first and then try to boot the system, it hangs on the mentioned point. However, when I firstly start my laptop and then when being in the login screen, I turn on my monitor, everything loads correctly.

Is this an issue that is to be discussed here or should I direct it to nvidia as it really seems the issue lies there?

Discussing it here seems fine to me. Not sure what else can be done.
I have fedora 36 on my machine and today did an update where all the nvidia bits for fedora 36 were updated from rpmfusion (their rpmfusion-nonfree-updates-testing repo) to 510.68 drivers. Will see if that fixes any of the issues I have had with F36 since I upgraded from F34. F36 is still beta though.

Ight, thank you for information. I believe I am using Fedora 35 (did not go for betas). May I ask if there are any issues regarding it on 36?

Before fedora, I used to run Arch on that machine for over a year and graphics with multi monitor setup was one of the main issues there.

I updated to fedora 36 with the newest drivers and the end result is a complete nightmare…
With proprietary drivers:
my second screen does not turn on at all (keeps being black), even though it is recognized in the gnome menu and I cannot find a way how to fix it - tried restarting monitor, restarting computer, etc. but it cannot be made to show relevant output (such as a DE)

With nouveau drivers:
Most of the time it is fine (display is recognized, gets signal on boot, performance is okay), however, system occasionally freezes (104222 – GNOME/Wayland desktop freezes when resizing Firefox window - idk if this is my case bc I use material shell because it brings tiling wm into gnome, so I cannot really resize screens hehe)… I tried installing XFCE and changed wayland (check appended link) to xorg and it seemed quite okay (no freeze) after a considerable amount of time… maybe it will freeze again, at this time, I have really no clue what to expect.

I am thinking about reporting this to redhat/maybe try consulting it with kernel devs/nvidia (I doubt this is the way their proprietary driver should work) as this is pretty unbelievable

But mainly brill thanks for support and help, I rly appreciate it

See the bug in bugzilla about external monitors. I have fedora 36 with nvidia and only see one real problem there.
I have the nvidia driver 510.60 on one desktop system and 510.68 on my laptop system, both from rpmfusion.
Fedora kernel 5.17.4
My laptop with the 510.68 driver is configured with the nvidia gpu as primary

Everything works well when using an xorg DE. When using wayland DE the external monitor does not work at all. The screen stays black.

This problem was seen with the 510.60 driver and I updated to the newer one in hopes it would be fixed, but no-go.

The way I was able to get the external and internal screens to both work was that I copied /usr/share/X11/xorg.conf.d/nvidia.conf to /etc/X11/xorg.conf.d/nvidia.conf and added Option "Primary" "yes" to both stanzas in that newly created file. After a reboot both screens would work under xorg but the external still does not work properly under wayland.

Brill thanks man!!
So basically it means that with nvidia proprietary drivers the solution (workaround) was to add the primary option both to:
/usr/share/X11/xorg.conf.d/nvidia.conf /etc/X11/xorg.conf.d/nvidia.conf

I expect this is not the nouveau case…

Only add it to the /etc/X11/xorg.conf.d/nvidia.conf file. The other is an example and this is the one actually used for config.

Right, thank you. I will keep this post open for some time if someone else would want to add something. However, I can say that the setup with nouveau drivers and xorg works fine so far.