Use of wacom pen freezes system under newest kernel

I’m using fc33.x86_64 on a thinkpad X1 carbon convertible (dual boot with win10). The wacom pen works fine under windows and under kernel 5.10.7-200.fc33.x86_64 but after kernel updates (5.10.8-200 or 5.10.9-201) the first use of the pen freezes the screen and the whole system. Only a complete reboot helps. Drawing on the screen with the finger or mouse works under all kernels, only the pen makes problems.

Any help or a newer and working kernel are welcome.

Thanks in advance, Michael

1 Like

I’ve seen other reports of something similar. See English Community-Lenovo Community


There are reports on bugzilla as well


Thank you very much. That seems to be a problem with kernels 5.10.8 and/or 5.10.9 but there seems to be hope since one reports says that the problem is solved in 5.10.10. I’ll try that later.

1 Like

Let us know if it works.

I’ve had two freezes since updating to 5.10.9 also, Plasma DE. No Wacom tablet, however, just routine use of Google Chrome and Thunderbird. I’m using 5.10.8 again and will report what happens when 5.10.10 becomes available. Fedora 33, btw.

Note, I am not using a Wacom pen, but earlier noted I had two freezes using kernel 5.10.9. and I went back to 5.10.8. I’m now on 5.10.10 and everything is running beautifully. I hope all is well with Mr. Kaplan too.

1 Like

I just updated to 5.10.10-200.fc33 but as soon as I touch the screen with the pen the machine still freezes. I had to reboot in 5.10.7-200.fc33 to have a working pen. A report in bugzilla said that this behaviour has been solved in kernel 5.10.10 in arch but it seems that this patch was not applied.

Yes, sorry for my previous post. I haven’t had any crashes using 5.10.10, but I’ve found weird artifacts these past couple of days with my graphics. Odd streaking of icons, poor rendering of my time and date in the system tray, blanking of my desktop background, possibly other things I haven’t noticed. I’m going to post something separately to get a better idea of how to report this as a bug. Crashes I can report, but flaky renderings I’m not too sure of. Sorry if I’ve interfered with what you are trying to fix.

dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-e04cde3ff0

installs 5.10.11-200.fc33.x86_64 and this kernel works with my pen.

Thanks a lot for all the help.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.