USB-audio on F36: either (monitor + playback) or (capture), not both


A few weeks ago, I discovered that F36 with Pipewire was able to run Jamulus, a software for jamming live with musicians all over the world without any noticeable latency. These days, I tried the setup again and discovered that my USB-audiointerface was no longer playing nice with Pipewire.

Output of inxi --system --audio:

  Host: WaanzinsPC2 Kernel: 5.19.9-200.fc36.x86_64 arch: x86_64 bits: 64
    Desktop: GNOME v: 42.5 Distro: Fedora release 36 (Thirty Six)
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    driver: snd_hda_intel
  Device-2: Intel 8 Series/C220 Series High Definition Audio
    driver: snd_hda_intel
  Device-3: M-Audio RunTime DFU / Fast Track Ultra 8R type: USB
    driver: snd-usb-audio
  Sound Server-1: ALSA v: k5.19.9-200.fc36.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.58 running: yes

Previously, when connected, in qpwgraph it would show up as three blocks of eight channels: 8x capture (IN), 8x monitor (IN) and 8x playback (OUT).

Since some update (and I cannot determine which one, but it could be weeks ago), it’s detected as 8x monitor (IN) and 8x playback (OUT) only.

While trying to figure this out, I started fiddeling with GNOME’s sound settings and then this happened: both blocks of 8 channels vanished, and one ‘capture’ block appeared in its place.

I tried to reproduce this, but ended up with the original 2x 8 channel blocks, without the ‘capture’ block.

How can this be solved? Is there a hidden duplex-setting somewhere I should know about?

Thanks for your help,

Case solved by looking through PulseAudio’s configuration. I have to set the interface’s profile to “Pro Audio” for both capture and playback to appear simultaneously.

Thanks for reading, sorry for the noise!

1 Like