Audio Output works fine, Audio Input does not

I’ve been searching around for a while and I cannot find any solutions to my issue.
I installed Fedora 36 a few days ago, and at the time I messed with pulseaudio/pipewire because nothing was working. I uninstalled both, and then installed pulseaudio. It seemed to be working, so I didn’t look into it further.

I have tried using three different audio input devices, none of which have worked. First one was a Blue Yeti Nano, second was an AUX headset microphone, and third was a USB webcam.

pavucontrol shows this no matter what. It just echoes whatever is playing in the output.

Server String: /run/user/6669/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 468
Tile Size: 65472
User Name: owocean
Host Name: batcave
Server Name: pulseaudio
Server Version: 15.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
Default Source: alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
Cookie: 2d49:b1e9

Here is the output of pactl info

**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: ALC887-VD Alt Analog [ALC887-VD Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and arecord -l

I just don’t know what to do. Do I need to use pipewire?? Any and all help is appreciated. Thank you.


Hi @owocean Do you use NVIdia? Howto/NVIDIA - RPM Fusion
Please tell us more about your hardware and configuration.

My nvidia drivers are already installed, though I don’t know how that would help my audio
NVIDIA GTX 1050 TI, Intel i5-8400, 24gb ram, MSI B360M

am i missing drivers for something? do i need to use something besides pulseaudio? is there a pulseaudio config i need to edit?

and if by some miracle, i tried plugging it in again just now and it shows up on my devices list. i didnt mess with any of the drivers.

problem solved ig