Updating your device name should also update the /etc/hosts file?

So, I’ve installed Fedora 33 recently, and left the device name as the default, which on the Gnome configuration app will be just fedora, but its actually localhost.localdomain by default.

When I changed the device name Firefox stoped working, and I found out it was because on my /etc/hosts the device name wasn’t updated, it was configured as so: localhost localhost.localdomain

Changing localhost.localdomain to the new device name fixed the issue with Firefox, but now I’m not sure if this was a problem with firefox or an oversight by gnome or fedora.

Here is a very good article on managing your hostname. It not only shows how to do it, but gives different methods and explains the pros and cons of them.

Setting your hostname